summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfademind2017-01-15 10:06:03 +0100
committerfademind2017-01-15 10:06:03 +0100
commit7e93258627d11c41adca26146cff379f37759314 (patch)
tree78a6cdc8c5d8861865b992c3ca8863a18f42b448
parentf6a82e248cbe6a8d1df9130f610b408d6a250e96 (diff)
downloadaur-7e93258627d11c41adca26146cff379f37759314.tar.gz
update
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD46
-rw-r--r--font.install15
4 files changed, 41 insertions, 42 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9230628e21fb..5ce69268f0df 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,10 @@
+# Generated by mksrcinfo v8
+# Sun Jan 15 09:06:03 UTC 2017
pkgbase = ttf-google-fonts-git
- pkgdesc = TrueType fonts from the Google Fonts project
- pkgver = 20161214
+ pkgdesc = TrueType fonts from the Google Fonts project (git version)
+ pkgver = 20170112
pkgrel = 1
url = https://github.com/google/fonts
- install = font.install
arch = any
license = various
makedepends = git
@@ -41,18 +42,23 @@ pkgbase = ttf-google-fonts-git
provides = ttf-lato
provides = ttf-lekton
provides = ttf-medievalsharp
+ provides = ttf-merriweather
+ provides = ttf-merriweather-sans
provides = ttf-noto
provides = ttf-nova
provides = ttf-oldstandard
provides = ttf-opensans
+ provides = ttf-oswald
provides = ttf-overpass
provides = ttf-oxygen
provides = ttf-oxygen-git
provides = ttf-pt-mono
provides = ttf-pt-sans
provides = ttf-ptsans
+ provides = ttf-quintessential
provides = ttf-roboto
provides = ttf-roboto-mono
+ provides = ttf-signika
provides = ttf-sil-fonts
provides = ttf-sortsmillgoudy
provides = ttf-source-code-pro
@@ -89,18 +95,23 @@ pkgbase = ttf-google-fonts-git
conflicts = ttf-lato
conflicts = ttf-lekton
conflicts = ttf-medievalsharp
+ conflicts = ttf-merriweather
+ conflicts = ttf-merriweather-sans
conflicts = ttf-noto
conflicts = ttf-nova
conflicts = ttf-oldstandard
conflicts = ttf-opensans
+ conflicts = ttf-oswald
conflicts = ttf-overpass
conflicts = ttf-oxygen
conflicts = ttf-oxygen-git
conflicts = ttf-pt-mono
conflicts = ttf-pt-sans
conflicts = ttf-ptsans
+ conflicts = ttf-quintessential
conflicts = ttf-roboto
conflicts = ttf-roboto-mono
+ conflicts = ttf-signika
conflicts = ttf-sil-fonts
conflicts = ttf-sortsmillgoudy
conflicts = ttf-source-code-pro
@@ -108,7 +119,7 @@ pkgbase = ttf-google-fonts-git
conflicts = ttf-ubuntu-font-family
conflicts = ttf-vollkorn
source = git+https://github.com/google/fonts.git
- md5sums = SKIP
+ sha256sums = SKIP
pkgname = ttf-google-fonts-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e087cfeaffa3
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+*
+!.gitignore
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
index a5e774c1484c..997a6aff308f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,5 @@
-# Maintainer: Vlad M. <vlad@archlinux.net>
+# Maintainer: FadeMind <fademind@gmail.com>
+# Contributor: Vlad M. <vlad@archlinux.net>
# Contributor: Sebastian Stammler <stammler.s@gmail.com>
# Contributor: Sarkasper <echo a2FzcGVyLm1lbnRlbkBnbXguY29tCg== | base64 -d>
# Contributor: Daniel Micay <danielmicay@gmail.com>
@@ -6,9 +7,9 @@
# Contributor: Alexander De Sousa <archaur.xandy21@spamgourmet.com>
pkgname=ttf-google-fonts-git
-pkgver=20161214
+pkgver=20170112
pkgrel=1
-pkgdesc="TrueType fonts from the Google Fonts project"
+pkgdesc="TrueType fonts from the Google Fonts project (git version)"
arch=('any')
url="https://github.com/google/fonts"
license=('various')
@@ -48,18 +49,23 @@ conflicts=('adobe-source-code-pro-fonts'
'ttf-lato'
'ttf-lekton'
'ttf-medievalsharp'
+ 'ttf-merriweather'
+ 'ttf-merriweather-sans'
'ttf-noto'
'ttf-nova'
'ttf-oldstandard'
'ttf-opensans'
+ 'ttf-oswald'
'ttf-overpass'
'ttf-oxygen'
'ttf-oxygen-git'
'ttf-pt-mono'
'ttf-pt-sans'
'ttf-ptsans'
+ 'ttf-quintessential'
'ttf-roboto'
'ttf-roboto-mono'
+ 'ttf-signika'
'ttf-sil-fonts'
'ttf-sortsmillgoudy'
'ttf-source-code-pro'
@@ -67,29 +73,23 @@ conflicts=('adobe-source-code-pro-fonts'
'ttf-ubuntu-font-family'
'ttf-vollkorn')
provides=("${conflicts[@]}" 'ttf-font')
-source=("git+https://github.com/google/fonts.git")
-md5sums=('SKIP')
-install=font.install
-
-# git variables
-_gitname="fonts"
+source=("git+${url}.git")
+sha256sums=('SKIP')
pkgver() {
- cd "$_gitname"
- git log -1 --format="%cd" --date=short | sed 's|-||g'
+ cd fonts
+ git log -1 --format="%cd" --date=short | sed 's|-||g'
}
package() {
- cd "$srcdir"
- install -dm755 "$pkgdir/usr/share/fonts/TTF"
- find . -type f -name \*.ttf -exec install -Dm644 '{}' \
- "$pkgdir/usr/share/fonts/TTF" \;
+ install -dm755 ${pkgdir}/usr/share/fonts/TTF
+ find . -type f -name \*.ttf -exec install -Dm644 '{}' ${pkgdir}/usr/share/fonts/TTF \;
- # remove Cantarell fonts because Google ships the original Cantarell
- # instead of the improved version of Cantarell shipped by the GNOME Project
- #
- # it is safe to remove "Cantarell-*.ttf" from this dir because the
- # cantarell-fonts package installs its fonts into /usr/share/fonts/cantarell/
- # and because cantarell-fonts installs .otf files instead of .ttf files
- find "${pkgdir}/usr/share/fonts/TTF" -type f -name "Cantarell-*.ttf" -delete
-}
+ # remove Cantarell fonts because Google ships the original Cantarell
+ # instead of the improved version of Cantarell shipped by the GNOME Project
+ #
+ # it is safe to remove "Cantarell-*.ttf" from this dir because the
+ # cantarell-fonts package installs its fonts into /usr/share/fonts/cantarell/
+ # and because cantarell-fonts installs .otf files instead of .ttf files
+ find ${pkgdir}/usr/share/fonts/TTF -type f -name "Cantarell-*.ttf" -delete
+ }
diff --git a/font.install b/font.install
deleted file mode 100644
index 7521b6991a1e..000000000000
--- a/font.install
+++ /dev/null
@@ -1,15 +0,0 @@
-post_install() {
- echo -n "Update font cache..."
- fc-cache -fs > /dev/null
- mkfontscale /usr/share/fonts/TTF
- mkfontdir /usr/share/fonts/TTF
- echo "done"
-}
-
-post_upgrade() {
- post_install $1
-}
-
-post_remove() {
- post_install $1
-} \ No newline at end of file