summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEdgard Castro2017-01-10 18:33:45 -0200
committerEdgard Castro2017-01-10 18:33:45 -0200
commit0e82955d14f4766748f70593b3489ff42ad20707 (patch)
tree77b6ee3c7ee0285a081bb2725999743d46db7f7c
downloadaur-0e82955d14f4766748f70593b3489ff42ad20707.tar.gz
initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD20
-rw-r--r--ttf-heuristica.install15
3 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..99e1341141d8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = ttf-heuristica
+ pkgdesc = A serif latin & cyrillic font, derived from the "Adobe Utopia" font by Apanov
+ pkgver = 1.0.2
+ pkgrel = 1
+ url = http://sourceforge.net/projects/heuristica/
+ install = ttf-heuristica.install
+ arch = any
+ license = custom:SIL Open Font License v1.1
+ depends = fontconfig
+ depends = xorg-fonts-encodings
+ depends = xorg-font-utils
+ source = http://downloads.sourceforge.net/project/heuristica/heuristica-ttf-1.0.2.tar.xz
+ sha256sums = 08bf21e44941d195dceab637c3d8e22f4b5ce8490c83993cebd85d721b92553d
+
+pkgname = ttf-heuristica
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0b0aeb528a9f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Edgard Castro <castro@edgard.org>
+# Contributor: Tyler Swagar <buttpickle69@shaw.ca>
+
+pkgname=ttf-heuristica
+pkgver=1.0.2
+pkgrel=1
+pkgdesc='A serif latin & cyrillic font, derived from the "Adobe Utopia" font by Apanov'
+arch=('any')
+url='http://sourceforge.net/projects/heuristica/'
+license=('custom:SIL Open Font License v1.1')
+depends=('fontconfig' 'xorg-fonts-encodings' 'xorg-font-utils')
+install="${pkgname}.install"
+source=("http://downloads.sourceforge.net/project/heuristica/heuristica-ttf-${pkgver}.tar.xz")
+sha256sums=('08bf21e44941d195dceab637c3d8e22f4b5ce8490c83993cebd85d721b92553d')
+
+package() {
+ install -dm 755 "${pkgdir}/usr/share/fonts/TTF"
+ install -m 644 *.ttf "${pkgdir}/usr/share/fonts/TTF/"
+ install -Dm644 OFL.txt "${pkgdir}/usr/share/licenses/$pkgname/LICENSE"
+}
diff --git a/ttf-heuristica.install b/ttf-heuristica.install
new file mode 100644
index 000000000000..43e14fbd0cff
--- /dev/null
+++ b/ttf-heuristica.install
@@ -0,0 +1,15 @@
+post_install() {
+ echo -n "Updating font cache... "
+ fc-cache -f > /dev/null
+ mkfontscale /usr/share/fonts/TTF
+ mkfontdir /usr/share/fonts/TTF
+ echo "done."
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}