summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndy Kluger2020-03-06 01:12:17 -0500
committerAndy Kluger2020-03-06 01:12:17 -0500
commit642776723dab2f68a236210b10f506c4eb6f5fc0 (patch)
tree516fe22b9e2ad63ad946312382d24557ac453a24
downloadaur-642776723dab2f68a236210b10f506c4eb6f5fc0.tar.gz
new name for formerly-iosevka-term
seems to build ok despite the gyp error in the beginning; open issue on iosevka's tracker
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD60
-rw-r--r--private-build-plans.toml.example101
-rw-r--r--toothless-G.patch32
4 files changed, 216 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..860323730ce3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = ttf-iosevka-fixed-custom-git
+ pkgdesc = A slender monospace sans-serif and slab-serif typeface inspired by Pragmata Pro, M+ and PF DIN Mono.
+ pkgver = r1448.7ff1f95c
+ pkgrel = 1
+ url = https://be5invis.github.io/Iosevka/
+ arch = any
+ license = custom:OFL
+ makedepends = git
+ makedepends = nodejs
+ makedepends = npm
+ makedepends = ttfautohint
+ makedepends = otfcc
+ depends = fontconfig
+ depends = xorg-font-utils
+ source = git+https://github.com/be5invis/Iosevka
+ source = private-build-plans.toml.example
+ source = toothless-G.patch
+ sha256sums = SKIP
+ sha256sums = 6004e471b9188445cc8c6c371384a42bedeecb1935765db1d82b4677b1342bc2
+ sha256sums = 56d1d97b421ab462d71875ecadf57d65ee45fe26edee50922ae9ae96350cff52
+
+pkgname = ttf-iosevka-fixed-custom-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3c6cf3df262d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,60 @@
+# Maintainer: Andy Kluger <AndyKluger@gmail.com>
+# Contributor: Markus Weimar <mail@markusweimar.de>
+pkgname=ttf-iosevka-fixed-custom-git
+pkgver=r1448.7ff1f95c
+pkgrel=1
+pkgdesc='A slender monospace sans-serif and slab-serif typeface inspired by Pragmata Pro, M+ and PF DIN Mono.'
+arch=('any')
+url='https://be5invis.github.io/Iosevka/'
+license=('custom:OFL')
+makedepends=('git' 'nodejs' 'npm' 'ttfautohint' 'otfcc')
+depends=('fontconfig' 'xorg-font-utils')
+conflicts=()
+provides=()
+source=(
+ "git+https://github.com/be5invis/Iosevka"
+ "private-build-plans.toml.example"
+ "toothless-G.patch"
+)
+sha256sums=(
+ 'SKIP'
+ '6004e471b9188445cc8c6c371384a42bedeecb1935765db1d82b4677b1342bc2'
+ '56d1d97b421ab462d71875ecadf57d65ee45fe26edee50922ae9ae96350cff52'
+)
+
+pkgver() {
+ cd Iosevka
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ buildplans="$HOME/.config/iosevka/private-build-plans.toml"
+ if [[ -f "$buildplans" ]]; then
+ cp "$buildplans" Iosevka/
+ else
+ echo ">>> $buildplans not found, using private-build-plans.toml.example"
+ cp private-build-plans.toml.example Iosevka/private-build-plans.toml
+ fi
+
+ cd Iosevka
+
+ # patch -p1 < ../toothless-G.patch
+
+ # Uncomment the above line to get back the smoother capital G,
+ # as seen in this image (look for "LIGHT"):
+ # https://raw.githubusercontent.com/be5invis/Iosevka/47023ab4058987f58844f6308d8175e735106b8a/images/preview-all.png
+}
+
+build() {
+ cd Iosevka
+ npm install
+ npm update
+ npm run build -- ttf::iosevka-fixed-custom
+}
+
+package() {
+ install -d "${pkgdir}/usr/share/fonts/TTF"
+ install -m644 Iosevka/dist/*/ttf/*.ttf "${pkgdir}/usr/share/fonts/TTF/"
+ install -d "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -m644 Iosevka/LICENSE.md "${pkgdir}/usr/share/licenses/${pkgname}/"
+}
diff --git a/private-build-plans.toml.example b/private-build-plans.toml.example
new file mode 100644
index 000000000000..649cb91a3872
--- /dev/null
+++ b/private-build-plans.toml.example
@@ -0,0 +1,101 @@
+# docs:
+# https://github.com/be5invis/Iosevka
+# https://github.com/be5invis/Iosevka/blob/master/private-build-plans.sample.toml
+# https://github.com/be5invis/Iosevka#build-your-own-style
+
+# ss## stylistic sets:
+# https://raw.githubusercontent.com/be5invis/Iosevka/master/images/stylesets.png
+
+# cv## character variants:
+# https://raw.githubusercontent.com/be5invis/Iosevka/master/images/charvars.png
+
+# ligset-* ligature sets:
+# https://raw.githubusercontent.com/be5invis/Iosevka/master/images/ligations.png
+
+[buildPlans.iosevka-custom] # Plan name
+family = "Iosevka Custom" # Font menu family name
+design = [ # Common styles
+
+ "cv05", # hooky i
+ "cv14", # dotted 0
+ "cv24", # open double story g
+ "cv26", # short leg m
+ "cv27", # tailed l
+ "cv33", # short @
+ "cv46", # flat top 3
+ "cv53", # tailed f
+ "cv54", # open short $
+ "cv60", # hex *
+ "cv69", # curly kK
+ "cv72", # curly vV
+ "cv74", # curly A
+ "cv76", # curly wW
+ "cv78", # curly xX
+ "cv79", # curly y
+ "cv81", # curly Y
+ "cv83", # curly R
+
+]
+# upright = [] # Upright-only styles
+# italic = [] # Italic-only styles
+# oblique = [] # Oblique-only styles
+
+[buildPlans.iosevka-fixed-custom] # Plan name
+family = "Iosevka Fixed Custom" # Font menu family name
+design = [ # Common styles
+
+ "fixed", # strict mono; no ligatures
+
+ "cv05", # hooky i
+ "cv14", # dotted 0
+ "cv24", # open double story g
+ "cv26", # short leg m
+ "cv27", # tailed l
+ "cv33", # short @
+ "cv46", # flat top 3
+ "cv53", # tailed f
+ "cv54", # open short $
+ "cv60", # hex *
+ "cv69", # curly kK
+ "cv72", # curly vV
+ "cv74", # curly A
+ "cv76", # curly wW
+ "cv78", # curly xX
+ "cv79", # curly y
+ "cv81", # curly Y
+ "cv83", # curly R
+
+]
+# upright = [] # Upright-only styles
+# italic = [] # Italic-only styles
+# oblique = [] # Oblique-only styles
+
+[buildPlans.iosevka-term-custom] # Plan name
+family = "Iosevka Term Custom" # Font menu family name
+design = [ # Common styles
+
+ "term", # strict mono; with ligatures
+
+ "cv05", # hooky i
+ "cv14", # dotted 0
+ "cv24", # open double story g
+ "cv26", # short leg m
+ "cv27", # tailed l
+ "cv33", # short @
+ "cv46", # flat top 3
+ "cv53", # tailed f
+ "cv54", # open short $
+ "cv60", # hex *
+ "cv69", # curly kK
+ "cv72", # curly vV
+ "cv74", # curly A
+ "cv76", # curly wW
+ "cv78", # curly xX
+ "cv79", # curly y
+ "cv81", # curly Y
+ "cv83", # curly R
+
+]
+# upright = [] # Upright-only styles
+# italic = [] # Italic-only styles
+# oblique = [] # Oblique-only styles
diff --git a/toothless-G.patch b/toothless-G.patch
new file mode 100644
index 000000000000..3e8f1fd61118
--- /dev/null
+++ b/toothless-G.patch
@@ -0,0 +1,32 @@
+diff --git a/glyphs/letters-unified-basic.ptl b/glyphs/letters-unified-basic.ptl
+index 40fb8784..5cd2ffae 100644
+--- a/glyphs/letters-unified-basic.ptl
++++ b/glyphs/letters-unified-basic.ptl
+@@ -2753,8 +2753,6 @@ export : define [apply] : begin
+ do "G and related ============================================================================="
+ define [GShape top sma smb] : glyph-construction
+ local yBar : top * 0.52 + STROKE * 0.25
+- local fine SHOULDERFINE
+- local sb : shoulderMidSlope fine nothing (-1)
+ include : dispiro
+ widths.lhs
+ g4 RIGHTSB (top - HOOK)
+@@ -2762,12 +2760,13 @@ export : define [apply] : begin
+ flat (SB + OX) (top - sma)
+ curl (SB + OX) smb
+ arcvh
+- g4.right.mid (MIDDLE + (CORRECTION_OMIDX - sb) * STROKE) O [widths.heading STROKE 0 {.y (1) .x (sb)}]
++ g4 (MIDDLE + CORRECTION_OMIDS) O
+ archv
+- straight.up.end (RIGHTSB - (STROKE - fine) * HVCONTRAST) sma [widths.heading fine 0 UPWARD]
+- include : HBarTop MIDDLE RIGHTSB yBar
+- include : VBarRight RIGHTSB sma yBar
+- include : VBarRight RIGHTSB sma 0 (STROKE - fine / 2)
++ flat RIGHTSB sma
++ curl RIGHTSB yBar [heading UPWARD]
++ include : dispiro
++ flat MIDDLE yBar [widths 0 STROKE]
++ curl RIGHTSB yBar [heading RIGHTWARD]
+
+ sketch # G
+ set-width WIDTH