summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTosuke2017-01-18 01:38:18 +0900
committerTosuke2017-01-18 01:38:18 +0900
commitbfc1a9f7431e89e165953fe4aa6b30ab41efbdd6 (patch)
tree323177c778720e54673347e473747e5572d6f12c
downloadaur-ttf-nasu.tar.gz
initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD27
-rw-r--r--ttf-nasu.install16
3 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4194256c1426
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Tue Jan 17 16:36:27 UTC 2017
+pkgbase = ttf-nasu
+ pkgdesc = Japanese TrueType font. Made by SourceHanSans, SourceCodePro and M+OUTLINEFONTS
+ pkgver = 20141215
+ pkgrel = 1
+ url = http://iij.dl.osdn.jp/users/7/7586/NasuFont-README.txt
+ install = ttf-nasu.install
+ arch = any
+ license = Apache
+ depends = fontconfig
+ depends = xorg-font-utils
+ source = https://ja.osdn.net/downloads/users/7/7587/NasuFont-20141215.zip
+ sha512sums = 899a0c488d1bd603be96606fb4b56b7fae9773c4d765c5cbc29e25953226ccbc9d5457301be7b7b7a99c8170ed4d685b5c0cae0ddeb90a95e97d884725a182cc
+
+pkgname = ttf-nasu
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0885f6369f41
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: tosuke <tasukeprg at gmail dot com>
+pkgname=ttf-nasu
+pkgver=20141215
+pkgrel=1
+pkgdesc="Japanese TrueType font. Made by SourceHanSans, SourceCodePro and M+OUTLINEFONTS"
+arch=('any')
+url="http://iij.dl.osdn.jp/users/7/7586/NasuFont-README.txt"
+license=('Apache')
+depends=('fontconfig' 'xorg-font-utils')
+install=$pkgname.install
+source=("https://ja.osdn.net/downloads/users/7/7587/NasuFont-20141215.zip")
+sha512sums=("899a0c488d1bd603be96606fb4b56b7fae9773c4d765c5cbc29e25953226ccbc9d5457301be7b7b7a99c8170ed4d685b5c0cae0ddeb90a95e97d884725a182cc")
+
+package() {
+ # install fonts
+ cd "$srcdir/NasuFont$pkgver/"
+
+ for ttf in $(ls *.ttf); do
+ install -Dm644 $ttf "$pkgdir/usr/share/fonts/TTF/$ttf"
+ done
+
+ # install License
+ cd "$srcdir/NasuFont$pkgver/"
+ install -Dm644 LICENSE.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE.txt"
+}
+
+
diff --git a/ttf-nasu.install b/ttf-nasu.install
new file mode 100644
index 000000000000..ae5c9072c92f
--- /dev/null
+++ b/ttf-nasu.install
@@ -0,0 +1,16 @@
+post_install() {
+ echo -n "Upgradeing font cache..."
+ fc-cache -fs > /dev/null
+ mkfontscale /usr/share/fonts/OTF
+ mkfontdir /usr/share/fonts/OTF
+ echo "done"
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}
+