summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHaoZeke2018-03-30 03:29:07 +0530
committerHaoZeke2018-03-30 03:29:07 +0530
commitfa788015fbb561f26a5a98e237dd7027ab45647f (patch)
tree2046fdfae4f599bb40cc0b64d5600ec30b177b65
downloadaur-ttf-neuton.tar.gz
First google font package
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD21
2 files changed, 35 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b2c0589c3a53
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = ttf-neuton
+ pkgdesc = Neuton is a clean, dark, somewhat Dutch-inspired serif font which reminds you a little of Times.
+ pkgver = 01git
+ pkgrel = 1
+ url = https://fonts.google.com/download?family=Neuton
+ arch = any
+ license = custom:SIL Open Font License
+ makedepends = unzip
+ provides = ttf-neuton
+ source = https://fonts.google.com/download?family=Neuton
+ sha256sums = SKIP
+
+pkgname = ttf-neuton
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e688666cc5f5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Rohit Goswami (HaoZeke) <rohit.goswami@aol.com>
+
+pkgname=ttf-neuton
+pkgver=01git
+pkgrel=1
+pkgdesc="Neuton is a clean, dark, somewhat Dutch-inspired serif font which reminds you a little of Times."
+url="https://fonts.google.com/download?family=Neuton"
+arch=(any)
+license=('custom:SIL Open Font License')
+makedepends=('unzip')
+provides=('ttf-neuton')
+source=("$url")
+sha256sums=('SKIP')
+
+package() {
+ install -d "$pkgdir/usr/share/fonts/${pkgname%-fonts}"
+ install -t "$pkgdir/usr/share/fonts/${pkgname%-fonts}" -m644 *.ttf
+ install -Dm644 OFL.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
+# vim:set ts=2 sw=2 et: