summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcaltlgin2020-11-08 05:39:24 +1300
committercaltlgin2020-11-08 05:39:24 +1300
commitf211c3c3590755550b046e5a4469e37aa5f83861 (patch)
treeac57e9bded274a31f59f73648c5f2b185b6c397d
downloadaur-tty-qlock.tar.gz
Add to AUR
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD37
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e5a3c3821864
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = tty-qlock
+ pkgdesc = Minimal, curses-based clock, for your terminal. Inspired by the QlockTwo by Biegert&Funk
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/joshdk/tty-qlock
+ arch = x86_64
+ license = BSD
+ makedepends = go
+ source = tty-qlock-1.0.0.tar.gz::https://github.com/joshdk/tty-qlock/archive/v1.0.0.tar.gz
+ sha256sums = 9a075e3d645910bb60946fd5d39aed1241c41868f3778a09d70099312dc39ba5
+
+pkgname = tty-qlock
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7abf43451607
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Caltlgin Stsodaat <contact@fossdaily.xyz>
+
+pkgname='tty-qlock'
+pkgver=1.0.0
+pkgrel=1
+pkgdesc='Minimal, curses-based clock, for your terminal. Inspired by the QlockTwo by Biegert&Funk'
+arch=('x86_64')
+url='https://github.com/joshdk/tty-qlock'
+license=('BSD')
+makedepends=('go')
+source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz")
+sha256sums=('9a075e3d645910bb60946fd5d39aed1241c41868f3778a09d70099312dc39ba5')
+
+prepare() {
+ export GOPATH="${srcdir}/gopath"
+ go clean -modcache
+}
+
+build() {
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+ export CGO_LDFLAGS="${LDFLAGS}"
+ export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
+
+ cd "${pkgname}-${pkgver}"
+ go build -v -o "${pkgname}" .
+}
+
+package() {
+ cd "${pkgname}-${pkgver}"
+ install -Dvm755 "${pkgname}" -t "${pkgdir}/usr/bin"
+ install -Dvm644 'README.md' -t "${pkgdir}/usr/share/doc/${pkgname}"
+ install -Dvm644 'LICENSE.txt' "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+
+# vim: ts=2 sw=2 et: