summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuilhem Saurel2024-03-25 11:44:35 +0100
committerGuilhem Saurel2024-03-25 11:44:39 +0100
commitb483950d3684745121bc8800afaf4062050ce004 (patch)
treecc734a075ab97cb2772f0c19e65d52300e2fb12e
parent66fff8bc8bf81bceb4871fd297d94fc71ea3e5bb (diff)
downloadaur-tulip.tar.gz
v5.7.3
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD34
-rw-r--r--cstdint.patch10
-rw-r--r--qwebengineview.patch11
-rw-r--r--tulip-894.patch11
5 files changed, 32 insertions, 48 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c868ec3e1567..531df4e9d5a5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = tulip
- pkgdesc = Tulip is an information visualization framework dedicated to the analysis and visualization of relational data.
- pkgver = 5.7.2
+ pkgdesc = An information visualization framework dedicated to the analysis and visualization of relational data.
+ pkgver = 5.7.3
pkgrel = 1
url = http://tulip.labri.fr/
arch = i686
@@ -26,11 +26,9 @@ pkgbase = tulip
depends = desktop-file-utils
optdepends = doxygen
optdepends = python-sphinx
- source = https://sourceforge.net/projects/auber/files/tulip/tulip-5.7.2/tulip-5.7.2_src.tar.gz
- source = cstdint.patch
- source = qwebengineview.patch
- sha256sums = 6fe5c5092e8ab3e129c3181817359d46899f0a91d79991d79eb40cf9948b37fd
- sha256sums = 9470d749a13c35dfe1eb1e648cb6ff4f5442ea2c3cb7c070c69647f2e49d0bee
- sha256sums = 20fd74005597463db1f8eb030e34da6e38a77e04cbdf7a0ba3e90cc258827436
+ source = https://sourceforge.net/projects/auber/files/tulip/tulip-5.7.3/tulip-5.7.3_src.tar.gz
+ source = tulip-894.patch
+ sha256sums = 6aba42f85b0360631fe3ba61b52cf28e3bc383f518652f9a90e7b90987da8dd5
+ sha256sums = 59430c405e5ce81729ed0582e3ec02b89b2e682341c3c79e12143e38c1558fad
pkgname = tulip
diff --git a/PKGBUILD b/PKGBUILD
index 5537ef68a11f..6fc23a9bdb1f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,9 +2,9 @@
# Contributor: Yunhui Fu <yhfudev@gmail.com>
pkgname=tulip
-pkgver=5.7.2
+pkgver=5.7.3
pkgrel=1
-pkgdesc='Tulip is an information visualization framework dedicated to the analysis and visualization of relational data.'
+pkgdesc='An information visualization framework dedicated to the analysis and visualization of relational data.'
arch=( 'i686' 'x86_64' 'armv6' 'armv6h' 'arm7h' )
url='http://tulip.labri.fr/'
license=('GPL')
@@ -33,15 +33,15 @@ optdepends=(
)
source=(
"https://sourceforge.net/projects/auber/files/tulip/tulip-${pkgver}/tulip-${pkgver}_src.tar.gz"
- "cstdint.patch" "qwebengineview.patch"
+ "tulip-894.patch"
)
-sha256sums=('6fe5c5092e8ab3e129c3181817359d46899f0a91d79991d79eb40cf9948b37fd'
- '9470d749a13c35dfe1eb1e648cb6ff4f5442ea2c3cb7c070c69647f2e49d0bee'
- '20fd74005597463db1f8eb030e34da6e38a77e04cbdf7a0ba3e90cc258827436')
+sha256sums=('6aba42f85b0360631fe3ba61b52cf28e3bc383f518652f9a90e7b90987da8dd5'
+ '59430c405e5ce81729ed0582e3ec02b89b2e682341c3c79e12143e38c1558fad')
-prepare() {
- patch -d "$pkgbase-$pkgver" -p0 -i $srcdir/cstdint.patch
- patch -d "$pkgbase-$pkgver" -p0 -i $srcdir/qwebengineview.patch
+prepare()
+{
+ cd "$pkgbase-$pkgver"
+ patch -p0 -i "$srcdir/tulip-894.patch"
}
build()
@@ -50,22 +50,18 @@ build()
-DTULIP_BUILD_TESTS=ON \
-DTULIP_USE_QT6=ON \
-DBUILD_SHARED_LIBS=ON \
+ -DCMAKE_INSTALL_LIBDIR=lib \
-DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_INSTALL_LIBDIR=lib
+ -Wno-dev
cmake --build "build-$pkgver"
}
#check() {
#cmake --build "build-$pkgver" -t test
- ##Error:
- ##33/35 Test #35: ExternalPluginsBuildTest.............***Failed 0.44 sec
- ##CMake Error at /home/nim/aur/tulip/src/build-5.7.1/thirdparty/sip-4.19.25/siplib/cmake_install.cmake:60 (file):
- ##file cannot create directory: /usr/lib/tulip/python/tulip/native. Maybe
- ##need administrative privileges.
- ##Call Stack (most recent call first):
- ##/home/nim/aur/tulip/src/build-5.7.1/thirdparty/sip-4.19.25/cmake_install.cmake:47 (include)
- ##/home/nim/aur/tulip/src/build-5.7.1/thirdparty/cmake_install.cmake:54 (include)
- ##/home/nim/aur/tulip/src/build-5.7.1/cmake_install.cmake:69 (include)
+ ##The following tests FAILED:
+ ##16 - PushPopTest (Subprocess aborted)
+ ##31 - TulipPluginsLoadingTest (Subprocess aborted)
+ ##35 - ExternalPluginsBuildTest (Failed)
#}
package() {
diff --git a/cstdint.patch b/cstdint.patch
deleted file mode 100644
index 7d21bc9538bf..000000000000
--- a/cstdint.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- library/tulip-core/src/PropertyTypes.cpp 2023-03-22 23:30:22.000000000 +0100
-+++ library/tulip-core/src/PropertyTypes.cpp 2023-05-09 12:11:41.996447295 +0200
-@@ -25,6 +25,7 @@
-
- #include <climits>
- #include <cfloat>
-+#include <cstdint>
-
- using namespace std;
- using namespace tlp;
diff --git a/qwebengineview.patch b/qwebengineview.patch
deleted file mode 100644
index b4689046e3e4..000000000000
--- a/qwebengineview.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- plugins/view/GeographicView/LeafletMaps.cpp 2023-03-22 23:30:22.000000000 +0100
-+++ plugins/view/GeographicView/LeafletMaps.cpp 2023-05-09 12:28:17.822332583 +0200
-@@ -131,7 +131,7 @@
- )";
-
- LeafletMaps::LeafletMaps(const std::vector<MapLayer> &mapLayers)
-- : QWEBVIEW(nullptr), mapLayers(mapLayers), currentLayer(0), inited(false) {
-+ : QWEBVIEW(static_cast<QWidget*>(nullptr)), mapLayers(mapLayers), currentLayer(0), inited(false) {
- #ifdef QT_HAS_WEBKIT
- // disable output of "libpng warning: iCCP: known incorrect sRGB profile"
- // due to QtWebKit ill-formed png files
diff --git a/tulip-894.patch b/tulip-894.patch
new file mode 100644
index 000000000000..f95cf92ef8fa
--- /dev/null
+++ b/tulip-894.patch
@@ -0,0 +1,11 @@
+--- library/tulip-gui/include/tulip/GlSimpleEntityItemModel.h.orig 2023-12-08 23:30:22.000000000 +0100
++++ library/tulip-gui/include/tulip/GlSimpleEntityItemModel.h 2024-03-25 11:22:33.748332055 +0100
+@@ -81,7 +81,7 @@
+ Q_ENUMS(SimpleEntityRole)
+
+ public:
+- enum SimpleEntityRole { SimpleEntityRole = Qt::UserRole + 1 };
++ enum class SimpleEntityRole { SimpleEntityRole = Qt::UserRole + 1 };
+
+ GlSimpleEntityItemModel(GlSimpleEntityItemEditor *itemEditor, QObject *parent = nullptr);
+ ~GlSimpleEntityItemModel() override;