summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHaochen Tong2017-06-12 00:42:01 +0800
committerHaochen Tong2017-06-12 00:42:01 +0800
commitb521605e606c6c94e8bb620577dc4cc4693e7557 (patch)
treef4b3d229581d44b884e53dc702a8b40ef0587af8
downloadaur-tunasay.tar.gz
newpkg
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD30
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a725fdaa3793
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Sun Jun 11 16:41:51 UTC 2017
+pkgbase = tunasay
+ pkgdesc = A configurable talking tuna
+ pkgver = 0.0.0+git01d877f
+ pkgrel = 1
+ url = https://github.com/tuna/tunasay
+ arch = any
+ license = MIT
+ makedepends = nodejs
+ makedepends = yarn
+ depends = nodejs
+ options = !strip
+ source = tunasay::git+https://github.com/tuna/tunasay#commit=01d877f52cb289e3e0202db32cbb45e97502c1e5
+ sha256sums = SKIP
+
+pkgname = tunasay
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c2623f18e902
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: hexchain <i@hexchain.org>
+
+pkgname=tunasay
+pkgver=0.0.0+git01d877f
+pkgrel=1
+pkgdesc="A configurable talking tuna"
+url="https://github.com/tuna/tunasay"
+license=("MIT")
+arch=("any")
+depends=("nodejs")
+makedepends=("nodejs" "yarn")
+source=("$pkgname::git+$url#commit=01d877f52cb289e3e0202db32cbb45e97502c1e5")
+sha256sums=('SKIP')
+options=(!strip)
+
+build() {
+ cd "$srcdir/$pkgname"
+ yarn install
+ chmod +x cli.js
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ install -Dm644 -t "$pkgdir/usr/share/licenses/$pkgname" LICENSE
+ install -dm755 "$pkgdir/usr/lib/" "$pkgdir/usr/bin"
+ cd "$srcdir"
+ cp -rv --no-preserve='ownership' "$srcdir/$pkgname" "$pkgdir/usr/lib/"
+ rm -rf "$pkgdir/usr/lib/$pkgname/.git"
+ ln -sf "/usr/lib/$pkgname/cli.js" "$pkgdir/usr/bin/tunasay"
+}