summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorManuel Hüsers2017-03-12 00:10:41 +0100
committerManuel Hüsers2017-03-12 00:10:41 +0100
commit51eb3c5f340d54c9d26372aa131b4dbc83792954 (patch)
tree80d8ce36ec0e4b635d9d3afdc4e4c1f2a4ddff1f
parentcab411550f57f2d1e8f7ed0aead4ceb90852d79a (diff)
downloadaur-51eb3c5f340d54c9d26372aa131b4dbc83792954.tar.gz
New package source
Updated the source URL because of the fedorahosted.org retirement
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD22
-rw-r--r--tuned.install2
3 files changed, 13 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 74e0a90b495e..59ccb71bbd1e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Tue Jan 24 10:29:55 UTC 2017
+# Sat Mar 11 23:05:15 UTC 2017
pkgbase = tuned
pkgdesc = Daemon that performs monitoring and adaptive configuration of devices in the system
pkgver = 2.7.1
@@ -19,9 +19,8 @@ pkgbase = tuned
depends = dbus-glib
optdepends = virt-what
optdepends = systemtap
- provides = tuned
backup = etc/tuned/active_profile
- source = https://fedorahosted.org/releases/t/u/tuned/tuned-2.7.1.tar.bz2
+ source = https://jskarvad.fedorapeople.org/tuned/download/tuned-2.7.1.tar.bz2
sha256sums = 03333eda9f3744ec214b1c20d0f79528a6438dafd5c79ff459b411414491802d
pkgname = tuned
diff --git a/PKGBUILD b/PKGBUILD
index a01fca98f588..760569802e49 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,5 @@
-# Maintainer: Iwan Timmer <irtimmer@gmail.com>
+# Maintainer: Manuel Hüsers <manuel.huesers@uni-ol.de>
+# Contributor: Iwan Timmer <irtimmer@gmail.com>
# Contributor: Timothée Ravier <tim at siosm dot fr>
# Contributor: Tom <reztho at archlinux dot org>
@@ -12,24 +13,21 @@ license=('GPL')
depends=('ethtool' 'python2-configobj' 'python2-pyudev' 'python2-gobject2' 'python2-decorator' 'python2-dbus' 'python2-gobject' 'dbus-glib')
optdepends=('virt-what' 'systemtap')
makedepends=('git')
-provides=('tuned')
backup=('etc/tuned/active_profile')
install="${pkgname}.install"
-source=("https://fedorahosted.org/releases/t/u/${pkgname}/${pkgname}-${pkgver}.tar.bz2")
+source=("https://jskarvad.fedorapeople.org/${pkgname}/download/${pkgname}-${pkgver}.tar.bz2")
sha256sums=('03333eda9f3744ec214b1c20d0f79528a6438dafd5c79ff459b411414491802d')
package() {
- cd ${pkgname}-${pkgver}
+ cd "${pkgname}-${pkgver}"
- make DESTDIR="${pkgdir}" install
+ make DESTDIR="${pkgdir}" install
- mv "${pkgdir}"/usr/sbin/* "${pkgdir}"/usr/bin/
- mv "${pkgdir}"/usr/libexec/tuned/* "${pkgdir}"/usr/lib/tuned/
- rm -r "${pkgdir}"/run "${pkgdir}"/usr/sbin "${pkgdir}"/usr/libexec
+ mv "${pkgdir}"/usr/sbin/* "${pkgdir}"/usr/bin/
+ mv "${pkgdir}"/usr/libexec/tuned/* "${pkgdir}"/usr/lib/tuned/
+ rm -r "${pkgdir}"/run "${pkgdir}"/usr/sbin "${pkgdir}"/usr/libexec
- find "${pkgdir}"/usr/bin/ -type f -exec sed -i 's@#!/usr/bin/python@#!/usr/bin/python2@' {} \;
+ find "${pkgdir}"/usr/bin/ -type f -exec sed -i 's@#!/usr/bin/python@#!/usr/bin/python2@' {} \;
- install -Dm 0644 "${srcdir}"/${pkgname}-${pkgver}/tuned.service "${pkgdir}"/usr/lib/systemd/system/tuned.service
+ install -Dm644 "${srcdir}/${pkgname}-${pkgver}/tuned.service" "${pkgdir}/usr/lib/systemd/system/tuned.service"
}
-
-# vim:set ts=2 sw=2 et:
diff --git a/tuned.install b/tuned.install
index dbe414b75382..a704b662c050 100644
--- a/tuned.install
+++ b/tuned.install
@@ -1,3 +1,3 @@
post_install() {
- systemd-tmpfiles --create tuned.conf
+ systemd-tmpfiles --create tuned.conf
}