summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Weber2022-04-09 20:07:00 -0500
committerThomas Weber2022-04-09 20:07:00 -0500
commit6a1e89823af919dbceac967d669554f14696b697 (patch)
treefe1b4ed0b758a4cc5752ba9a9f50451a1e6138fc
parentef24f2f6ae8683bd9163cedb8c63af9ee0b44cc6 (diff)
downloadaur-6a1e89823af919dbceac967d669554f14696b697.tar.gz
Update to electron 17
Electron 18 is causing crashes for an unknown reason
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD6
-rw-r--r--turbowarp-desktop-bin.sh2
3 files changed, 7 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7d3c8e5c0888..9683e98a999e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,18 @@
pkgbase = turbowarp-desktop-bin
pkgdesc = Scratch mod with a compiler to run projects faster, dark mode for your eyes, a bunch of addons to improve the editor, and more.
pkgver = 1.1.3
- pkgrel = 1
+ pkgrel = 2
url = https://desktop.turbowarp.org/
arch = any
license = GPL3
- depends = electron16
+ depends = electron17
noextract = turbowarp-desktop-bin-1.1.3.tar.gz
source = turbowarp-desktop-bin-1.1.3.tar.gz::https://github.com/TurboWarp/desktop/releases/download/v1.1.3/TurboWarp-linux-armv7l-1.1.3.tar.gz
source = turbowarp-desktop-bin.sh
source = turbowarp-desktop-bin.desktop
source = turbowarp-desktop-bin.xml
sha256sums = cf8940164ab316812150e984c0ba648aabfab899d0631a1a33178a1dd386c661
- sha256sums = 57925a22a0f99186d57314015d6ab10e1e483adf78b060a1b7ac616b24ad1a7f
+ sha256sums = defc58d3fe0c5fbfd7b5edef2137a78dc9c4acd8cf9e78ee6118bbce65c22d9a
sha256sums = efd2cc6c3f4e2de57a823f6587ca1c3c3b318618e94e2c1e9c14844e36fa8c4b
sha256sums = 172c033a4652e69cd6e3830e56d736f7e3a11b9315bd689227788ce13dc83913
diff --git a/PKGBUILD b/PKGBUILD
index ddcb3733d6f9..92938dc2adf2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,12 +2,12 @@
pkgname=turbowarp-desktop-bin
pkgver=1.1.3
-pkgrel=1
+pkgrel=2
pkgdesc="Scratch mod with a compiler to run projects faster, dark mode for your eyes, a bunch of addons to improve the editor, and more."
arch=("any")
url="https://desktop.turbowarp.org/"
license=("GPL3")
-depends=("electron16")
+depends=("electron17")
source=(
"$pkgname-$pkgver.tar.gz::https://github.com/TurboWarp/desktop/releases/download/v$pkgver/TurboWarp-linux-armv7l-$pkgver.tar.gz"
"$pkgname.sh"
@@ -16,7 +16,7 @@ source=(
)
noextract=("$pkgname-$pkgver.tar.gz")
sha256sums=('cf8940164ab316812150e984c0ba648aabfab899d0631a1a33178a1dd386c661'
- '57925a22a0f99186d57314015d6ab10e1e483adf78b060a1b7ac616b24ad1a7f'
+ 'defc58d3fe0c5fbfd7b5edef2137a78dc9c4acd8cf9e78ee6118bbce65c22d9a'
'efd2cc6c3f4e2de57a823f6587ca1c3c3b318618e94e2c1e9c14844e36fa8c4b'
'172c033a4652e69cd6e3830e56d736f7e3a11b9315bd689227788ce13dc83913')
diff --git a/turbowarp-desktop-bin.sh b/turbowarp-desktop-bin.sh
index eb701b3fcac6..f1a751a312c9 100644
--- a/turbowarp-desktop-bin.sh
+++ b/turbowarp-desktop-bin.sh
@@ -1,2 +1,2 @@
#!/bin/sh
-exec electron16 /usr/share/turbowarp-desktop/app.asar "$@"
+exec electron17 /usr/share/turbowarp-desktop/app.asar "$@"