summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGarboMuffin2023-01-24 18:27:02 -0600
committerGarboMuffin2023-01-24 18:27:02 -0600
commitb9457edd6c39436f4d7f7ef70a1319978359e124 (patch)
treee4c6557c031e204c4e679e46a7b4b606fe389f66
parent350bfce3ee2597fe1cbc5fa12537617ef7f53cbe (diff)
downloadaur-b9457edd6c39436f4d7f7ef70a1319978359e124.tar.gz
Update to 1.7.0
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD8
-rw-r--r--turbowarp-desktop-bin.sh2
3 files changed, 10 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 30aaf2587a7a..e532d6fc00df 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,17 @@
pkgbase = turbowarp-desktop-bin
pkgdesc = Scratch mod with a compiler to run projects faster, dark mode for your eyes, a bunch of addons to improve the editor, and more.
- pkgver = 1.6.1
+ pkgver = 1.7.0
pkgrel = 1
url = https://desktop.turbowarp.org/
arch = any
license = GPL3
- depends = electron20
- noextract = turbowarp-desktop-bin-1.6.1.tar.gz
- source = turbowarp-desktop-bin-1.6.1.tar.gz::https://github.com/TurboWarp/desktop/releases/download/v1.6.1/TurboWarp-linux-armv7l-1.6.1.tar.gz
+ depends = electron22
+ noextract = turbowarp-desktop-bin-1.7.0.tar.gz
+ source = turbowarp-desktop-bin-1.7.0.tar.gz::https://github.com/TurboWarp/desktop/releases/download/v1.7.0/TurboWarp-linux-armv7l-1.7.0.tar.gz
source = turbowarp-desktop-bin.sh
source = turbowarp-desktop-bin.desktop
source = turbowarp-desktop-bin.xml
- sha256sums = 3fb961a865ff7439e23c3b2083c373009edf106b986f5347bb193b25e21be2cb
+ sha256sums = bee65e7faa34ba9ddff3df1a1605acca9a943ee7d7b427e6890806cf322f0098
sha256sums = 808433b46c27b279b9a721e3f6a8389b8914e85824b012a11d5d6d29f7663293
sha256sums = d2f66e5f85b4996d264f40142745203642b1339f77b1a99e3301092f82cfbf55
sha256sums = 931f2718e03cb9ecbdd25bf65b0e22c3d8479eb473b89cd0de26e9193738d660
diff --git a/PKGBUILD b/PKGBUILD
index cb12eab3b837..703e292f7020 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Maintainer: Thomas Weber <contact at turbowarp dot org>
pkgname=turbowarp-desktop-bin
-pkgver=1.6.1
+pkgver=1.7.0
pkgrel=1
pkgdesc="Scratch mod with a compiler to run projects faster, dark mode for your eyes, a bunch of addons to improve the editor, and more."
arch=("any")
url="https://desktop.turbowarp.org/"
license=("GPL3")
-depends=("electron20")
+depends=("electron22")
source=(
"$pkgname-$pkgver.tar.gz::https://github.com/TurboWarp/desktop/releases/download/v$pkgver/TurboWarp-linux-armv7l-$pkgver.tar.gz"
"$pkgname.sh"
@@ -15,8 +15,8 @@ source=(
"$pkgname.xml"
)
noextract=("$pkgname-$pkgver.tar.gz")
-sha256sums=('3fb961a865ff7439e23c3b2083c373009edf106b986f5347bb193b25e21be2cb'
- '808433b46c27b279b9a721e3f6a8389b8914e85824b012a11d5d6d29f7663293'
+sha256sums=('bee65e7faa34ba9ddff3df1a1605acca9a943ee7d7b427e6890806cf322f0098'
+ 'ce1d01133f7cb62bc96e1c9bcb2b2c7e935e98235d036a802c388bf1760a878b'
'd2f66e5f85b4996d264f40142745203642b1339f77b1a99e3301092f82cfbf55'
'931f2718e03cb9ecbdd25bf65b0e22c3d8479eb473b89cd0de26e9193738d660')
diff --git a/turbowarp-desktop-bin.sh b/turbowarp-desktop-bin.sh
index c92c3683e467..60f17eb24744 100644
--- a/turbowarp-desktop-bin.sh
+++ b/turbowarp-desktop-bin.sh
@@ -1,2 +1,2 @@
#!/bin/sh
-exec electron20 /usr/share/turbowarp-desktop/app.asar "$@"
+exec electron22 /usr/share/turbowarp-desktop/app.asar "$@"