summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMuffin2024-03-03 22:00:45 -0600
committerMuffin2024-03-03 22:00:45 -0600
commitbdf6ce6c74e21283564eb88af77be01dca63849b (patch)
tree331a7d689e1f49b850f685f45a5d5472a188fbfe
parent88cf0a0ddde51af8bf8c57703772146ef500ce17 (diff)
downloadaur-bdf6ce6c74e21283564eb88af77be01dca63849b.tar.gz
Update Electron to 28
Electron 26 is causing WebGL errors on some systems: https://github.com/TurboWarp/desktop/issues/938 https://github.com/TurboWarp/desktop/issues/940 Updating Electron fixes this in the flatpak. Expect the same to apply to Arch. Ideally we would go to Electron 29 but that package seems to be broken on my test system so I'll try that again later.
-rw-r--r--PKGBUILD6
-rw-r--r--turbowarp-desktop-bin.sh2
2 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6849823bc8e3..389e4edfa5ef 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,12 +2,12 @@
pkgname=turbowarp-desktop-bin
pkgver=1.10.1
-pkgrel=1
+pkgrel=2
pkgdesc="Scratch mod with a compiler to run projects faster, dark mode for your eyes, a bunch of addons to improve the editor, and more."
arch=("any")
url="https://desktop.turbowarp.org/"
license=("GPL3")
-depends=("electron26")
+depends=("electron28")
source=(
"$pkgname-$pkgver.tar.gz::https://github.com/TurboWarp/desktop/releases/download/v$pkgver/TurboWarp-linux-armv7l-$pkgver.tar.gz"
"$pkgname.sh"
@@ -16,7 +16,7 @@ source=(
)
noextract=("$pkgname-$pkgver.tar.gz")
sha256sums=('03fc95bbd6d5cff3e012b82371606a27b5a3a98413436c1926ebd0b915c31ec3'
- '1e0fec35bd09b28a95e002622577dd70a8b76978f40a30975793d78a8bdf593a'
+ '01cdf1090e087ccabb63f06feed3c8814d7acac8c8b1e32c76a60499abdf8be7'
'd2f66e5f85b4996d264f40142745203642b1339f77b1a99e3301092f82cfbf55'
'931f2718e03cb9ecbdd25bf65b0e22c3d8479eb473b89cd0de26e9193738d660')
diff --git a/turbowarp-desktop-bin.sh b/turbowarp-desktop-bin.sh
index 6f05b86f4226..d2d7f852eef3 100644
--- a/turbowarp-desktop-bin.sh
+++ b/turbowarp-desktop-bin.sh
@@ -1,2 +1,2 @@
#!/bin/sh
-exec electron26 /usr/share/turbowarp-desktop/app.asar "$@"
+exec electron28 /usr/share/turbowarp-desktop/app.asar "$@"