summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Weber2021-12-20 21:12:56 -0600
committerThomas Weber2021-12-20 21:16:24 -0600
commitf46095a7e344589cbaaa0da70ad78fd75376b6be (patch)
treefdfec6fc8bd605baa04cb9df1e279106d53a2f9c
downloadaur-f46095a7e344589cbaaa0da70ad78fd75376b6be.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD35
-rw-r--r--turbowarp-desktop-bin.desktop10
-rw-r--r--turbowarp-desktop-bin.sh2
-rw-r--r--turbowarp-desktop-bin.xml7
6 files changed, 77 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a5cfcfe127ab
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = turbowarp-desktop-bin
+ pkgdesc = Scratch mod with a compiler to run projects faster, dark mode for your eyes, a bunch of addons to improve the editor, and more.
+ pkgver = 0.14.1
+ pkgrel = 1
+ url = https://desktop.turbowarp.org/
+ arch = any
+ license = GPL3
+ depends = electron
+ noextract = turbowarp-desktop-bin-0.14.1.tar.gz
+ source = turbowarp-desktop-bin-0.14.1.tar.gz::https://github.com/TurboWarp/desktop/releases/download/v0.14.1/TurboWarp-linux-armv7l-0.14.1.tar.gz
+ source = turbowarp-desktop-bin.sh
+ source = turbowarp-desktop-bin.desktop
+ source = turbowarp-desktop-bin.xml
+ sha256sums = df4b2d4765c3bcd4702b65756fedbd452252201a68f46cbdbdfd92e6b12765da
+ sha256sums = 7752c9bcf60a857053b3a4262a40dd6ed2997044814dfb39e19cfa7108bcdfe4
+ sha256sums = efd2cc6c3f4e2de57a823f6587ca1c3c3b318618e94e2c1e9c14844e36fa8c4b
+ sha256sums = 172c033a4652e69cd6e3830e56d736f7e3a11b9315bd689227788ce13dc83913
+
+pkgname = turbowarp-desktop-bin
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..75d5205291c6
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg
+src
+*.pkg.*
+*.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..09aaae56b7cb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Thomas Weber <weber_t+aur at mailbox dot org>
+
+pkgname=turbowarp-desktop-bin
+pkgver=0.14.1
+pkgrel=1
+pkgdesc="Scratch mod with a compiler to run projects faster, dark mode for your eyes, a bunch of addons to improve the editor, and more."
+arch=("any")
+url="https://desktop.turbowarp.org/"
+license=("GPL3")
+depends=("electron")
+source=(
+ "$pkgname-$pkgver.tar.gz::https://github.com/TurboWarp/desktop/releases/download/v$pkgver/TurboWarp-linux-armv7l-$pkgver.tar.gz"
+ "$pkgname.sh"
+ "$pkgname.desktop"
+ "$pkgname.xml"
+)
+noextract=("$pkgname-$pkgver.tar.gz")
+sha256sums=('df4b2d4765c3bcd4702b65756fedbd452252201a68f46cbdbdfd92e6b12765da'
+ '7752c9bcf60a857053b3a4262a40dd6ed2997044814dfb39e19cfa7108bcdfe4'
+ 'efd2cc6c3f4e2de57a823f6587ca1c3c3b318618e94e2c1e9c14844e36fa8c4b'
+ '172c033a4652e69cd6e3830e56d736f7e3a11b9315bd689227788ce13dc83913')
+
+prepare() {
+ mkdir -p "$srcdir/$pkgname-$pkgver"
+ bsdtar -xf "$pkgname-$pkgver.tar.gz" -C "$srcdir/$pkgname-$pkgver" --strip-components 1
+}
+
+package() {
+ install -Dm755 "$pkgname.sh" "$pkgdir/usr/bin/turbowarp-desktop"
+ install -Dm755 "$pkgname.desktop" "$pkgdir/usr/share/applications/turbowarp-desktop.desktop"
+ install -Dm644 "$pkgname.xml" "$pkgdir/usr/share/mime/packages/turbowarp-desktop.xml"
+ install -Dm644 "$srcdir/$pkgname-$pkgver/resources/static/icon.png" "$pkgdir/usr/share/icons/hicolor/512x512/apps/turbowarp-desktop.png"
+ mkdir -p "$pkgdir/usr/share/turbowarp-desktop"
+ cp -r $srcdir/$pkgname-$pkgver/resources/* "$pkgdir/usr/share/turbowarp-desktop"
+}
diff --git a/turbowarp-desktop-bin.desktop b/turbowarp-desktop-bin.desktop
new file mode 100644
index 000000000000..51dd9e3a9859
--- /dev/null
+++ b/turbowarp-desktop-bin.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Name=TurboWarp
+Exec=turbowarp-desktop %U
+Terminal=false
+Type=Application
+Icon=turbowarp-desktop
+StartupWMClass=TurboWarp
+Comment=TurboWarp is a Scratch mod with a compiler to run projects faster, dark mode for your eyes, a bunch of addons to improve the editor, and more.
+MimeType=application/x.scratch.sb3;
+Categories=Development;
diff --git a/turbowarp-desktop-bin.sh b/turbowarp-desktop-bin.sh
new file mode 100644
index 000000000000..e974d35977f1
--- /dev/null
+++ b/turbowarp-desktop-bin.sh
@@ -0,0 +1,2 @@
+#!/bin/sh
+exec electron /usr/share/turbowarp-desktop/app.asar "$@"
diff --git a/turbowarp-desktop-bin.xml b/turbowarp-desktop-bin.xml
new file mode 100644
index 000000000000..adcab24c9fd8
--- /dev/null
+++ b/turbowarp-desktop-bin.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="utf-8"?>
+<mime-info xmlns="http://www.freedesktop.org/standards/shared-mime-info">
+<mime-type type="application/x.scratch.sb3">
+ <glob pattern="*.sb3"/>
+ <icon name="turbowarp-desktop"/>
+</mime-type>
+</mime-info>