summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRasmus Lindroth2022-05-27 13:51:20 +0200
committerRasmus Lindroth2022-05-27 13:51:20 +0200
commit0a2eaee87eb701828adffc39fa4def58207707dd (patch)
tree013996a080339f983b3f94ff7eafa995df5cd78d
parentb4b394840b6b8b0ac70c07d99d0ca0ceb382abbd (diff)
downloadaur-0a2eaee87eb701828adffc39fa4def58207707dd.tar.gz
add dynamic layout
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD11
2 files changed, 12 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ef210c0b3fcf..62f91d9715fc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,13 @@
pkgbase = tut
pkgdesc = A TUI for Mastodon with vim inspired keys
- pkgver = 1.0.9
+ pkgver = 1.0.10
pkgrel = 1
url = https://github.com/RasmusLindroth/tut
arch = any
license = MIT
makedepends = go
- source = https://github.com/RasmusLindroth/tut/archive/refs/tags/1.0.9.tar.gz
- sha256sums = 67c48a6e8f28e01f61aeb62566601bf88f5afc5a917f0d2e4b97d215330c245e
+ conflicts = tut-bin
+ source = tut-1.0.10.tar.gz::https://github.com/RasmusLindroth/tut/archive/refs/tags/1.0.10.tar.gz
+ sha256sums = 010e4d87bcae72b03c3f2fcf1396f9a1d0271d323abb9f27099dbdc1e1137245
pkgname = tut
diff --git a/PKGBUILD b/PKGBUILD
index 82e26c6e3e30..7b33a6d408c8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,15 @@
# Maintainer: Rasmus Lindroth <rasmus@lindroth.xyz>
pkgname=tut
-pkgver=1.0.9
+pkgver=1.0.10
pkgrel=1
pkgdesc='A TUI for Mastodon with vim inspired keys'
arch=('any')
+conflicts=('tut-bin')
url="https://github.com/RasmusLindroth/$pkgname"
license=('MIT')
makedepends=('go')
-source=("https://github.com/RasmusLindroth/$pkgname/archive/refs/tags/$pkgver.tar.gz")
-sha256sums=('67c48a6e8f28e01f61aeb62566601bf88f5afc5a917f0d2e4b97d215330c245e')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/RasmusLindroth/$pkgname/archive/refs/tags/$pkgver.tar.gz")
+sha256sums=('010e4d87bcae72b03c3f2fcf1396f9a1d0271d323abb9f27099dbdc1e1137245')
build() {
cd $pkgname-$pkgver
@@ -21,5 +22,9 @@ build() {
package() {
cd $pkgname-$pkgver
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+ install -Dm644 config.example.ini "$pkgdir"/usr/share/doc/$pkgname/config.example.ini
+ install -Dm644 config/toot.tmpl "$pkgdir"/usr/share/doc/$pkgname/toot.tmpl
+ install -Dm644 config/user.tmpl "$pkgdir"/usr/share/doc/$pkgname/user.tmpl
install -Dm755 $pkgname "$pkgdir"/usr/bin/$pkgname
}