summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorava1ar2015-06-17 00:49:41 -0400
committerava1ar2015-06-17 00:49:41 -0400
commitaf91eade940feca8711e335878ba4f04feb11310 (patch)
tree603738588251bef29646aacfe05689c11fc19aa6
downloadaur-tuxboot-git.tar.gz
Initial import
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD41
2 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f27d4864d0ff
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = tuxboot-git
+ pkgdesc = A tool that helps you to create a bootable Live USB drive for Clonezilla live, DRBL live, GParted live and Tux2live. Development version
+ pkgver = 0.8.r2.gfced5c1
+ pkgrel = 1
+ url = http://www.tuxboot.org/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = syslinux
+ depends = qt4
+ depends = mtools
+ depends = polkit
+ conflicts = tuxboot
+ source = git+git://git.code.sf.net/p/tuxboot/git
+ sha1sums = SKIP
+
+pkgname = tuxboot-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8e34b2d35594
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Contributor: Simone Sclavi 'Ito' <darkhado@gmail.com>
+# Maintainer: ava1ar <mail(at)ava1ar(dot)me>
+
+pkgname=tuxboot-git
+_pkgname=tuxboot
+pkgver=0.8.r2.gfced5c1
+pkgrel=1
+pkgdesc="A tool that helps you to create a bootable Live USB drive for Clonezilla live, DRBL live, GParted live and Tux2live. Development version"
+url="http://www.tuxboot.org/"
+license=('GPL')
+arch=('i686' 'x86_64')
+source=("git+git://git.code.sf.net/p/tuxboot/git")
+sha1sums=('SKIP')
+depends=('syslinux' 'qt4' 'mtools' 'polkit')
+makepdepends=('git')
+conflicts=('tuxboot')
+
+pkgver() {
+ cd git
+ echo $(git describe --long --tags | sed -E 's/([^-]*-g)/r\1/;s/-/./g')
+}
+
+build() {
+ cd git
+ sed -i '/\[en_US\]/d' ${_pkgname}.desktop
+ sed -i '/^RESOURCES/d' ${_pkgname}.pro
+ lupdate-qt4 ${_pkgname}.pro
+ lrelease-qt4 ${_pkgname}.pro
+ qmake-qt4 "DEFINES += NOSTATIC" "RESOURCES -= tuxboot.qrc"
+ make
+}
+
+package() {
+ cd git
+ install -Dm755 ${_pkgname} ${pkgdir}/usr/bin/${_pkgname}
+ install -Dm755 ${_pkgname}-pkexec ${pkgdir}/usr/bin/${_pkgname}-pkexec
+ mkdir -p ${pkgdir}/usr/share/${_pkgname}
+ install -m644 i18n/${_pkgname}_*.qm ${pkgdir}/usr/share/${_pkgname}/
+ install -Dm644 ${_pkgname}.desktop ${pkgdir}/usr/share/applications/${_pkgname}.desktop
+ install -Dm644 ${_pkgname}.xpm ${pkgdir}/usr/share/pixmaps/${_pkgname}.xpm
+}