summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoroi_wtf2024-03-19 12:11:02 +0100
committeroi_wtf2024-03-19 12:11:02 +0100
commit52a2b25a281c7719c302f1767ac1bb66f56ddbfe (patch)
tree73eb76742e580ab55071598f8f24bfe932f97547
parent3caf3e786a1e7703f0cb56a6005740707363eadf (diff)
downloadaur-tuxedo-touchpad-switch.tar.gz
upgpkg: tuxedo-touchpad-switch 1.0.7-2
add patch to talk to kded6 instead of kded5
-rw-r--r--.SRCINFO6
-rw-r--r--0001-use_kded6_instead_of_kded5.patch25
-rw-r--r--PKGBUILD15
3 files changed, 37 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 884b072bfe4b..5609c6fcaa04 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = tuxedo-touchpad-switch
pkgdesc = A Linux userspace driver to enable and disable the touchpads on TongFang/Uniwill laptops
pkgver = 1.0.7
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/tuxedocomputers/tuxedo-touchpad-switch
arch = x86_64
license = GPL3
@@ -12,6 +12,8 @@ pkgbase = tuxedo-touchpad-switch
provides = tuxedo-touchpad-switch
conflicts = tuxedo-touchpad-switch
source = git+https://github.com/tuxedocomputers/tuxedo-touchpad-switch.git#commit=78f47d6c21429c188a4742f5d39e09767b54f3ae
- sha256sums = SKIP
+ source = 0001-use_kded6_instead_of_kded5.patch
+ sha256sums = 21cb0dfe08a74585f0729f0db29dd7a20e3f7f8045265d7c28c5743e8f30d940
+ sha256sums = 68fb24f5ac87613458d438d5993e1a397f102d5db2e6dc12fef1635ad090351f
pkgname = tuxedo-touchpad-switch
diff --git a/0001-use_kded6_instead_of_kded5.patch b/0001-use_kded6_instead_of_kded5.patch
new file mode 100644
index 000000000000..fffb47a3beed
--- /dev/null
+++ b/0001-use_kded6_instead_of_kded5.patch
@@ -0,0 +1,25 @@
+diff --git a/setup-kde.cpp b/setup-kde.cpp
+index b4f9980..b3966cc 100644
+--- a/setup-kde.cpp
++++ b/setup-kde.cpp
+@@ -164,9 +164,9 @@ int setup_kde(int lockfile_arg) {
+
+ GDBusProxy *kded5 = g_dbus_proxy_new_for_bus_sync(G_BUS_TYPE_SESSION,
+ G_DBUS_PROXY_FLAGS_NONE, NULL,
+- "org.kde.kded5",
++ "org.kde.kded6",
+ "/kded",
+- "org.kde.kded5",
++ "org.kde.kded6",
+ NULL, NULL);
+ if (kded5 == NULL) {
+ cerr << "setup_kde(...): g_dbus_proxy_new_for_bus_sync(...) failed." << endl;
+@@ -209,7 +209,7 @@ int setup_kde(int lockfile_arg) {
+ // sync on config and xsession change
+ kded5_modules_touchpad = g_dbus_proxy_new_for_bus_sync(G_BUS_TYPE_SESSION,
+ G_DBUS_PROXY_FLAGS_NONE, NULL,
+- "org.kde.kded5",
++ "org.kde.kded6",
+ object_path,
+ "org.kde.touchpad",
+ NULL, NULL);
diff --git a/PKGBUILD b/PKGBUILD
index aef756939f91..de686bc2b057 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=tuxedo-touchpad-switch
pkgver=1.0.7
-pkgrel=1
+pkgrel=2
pkgdesc="A Linux userspace driver to enable and disable the touchpads on TongFang/Uniwill laptops"
url="https://github.com/tuxedocomputers/tuxedo-touchpad-switch"
arch=(x86_64)
@@ -18,14 +18,15 @@ _commit="78f47d6c21429c188a4742f5d39e09767b54f3ae" # tag v1.0.7
#https://github.com/tuxedocomputers/tuxedo-touchpad-switch/archive/v$pkgver/${pkgname}-${pkgver}.tar.gz
source=(
git+https://github.com/tuxedocomputers/tuxedo-touchpad-switch.git#commit=$_commit
+ 0001-use_kded6_instead_of_kded5.patch
)
-sha256sums=(
- SKIP
-)
+sha256sums=('21cb0dfe08a74585f0729f0db29dd7a20e3f7f8045265d7c28c5743e8f30d940'
+ '68fb24f5ac87613458d438d5993e1a397f102d5db2e6dc12fef1635ad090351f')
-#prepare() {
-# cd "${pkgname}"
-#}
+prepare() {
+ cd "${pkgname}"
+ patch -Np1 < "${srcdir}"/0001-use_kded6_instead_of_kded5.patch
+}
build() {
cd "${pkgname}"