summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex Mekkering2017-04-23 11:09:03 +0200
committerAlex Mekkering2017-04-23 11:09:03 +0200
commit1719abb709632de25758d27343bcba91ae6ade70 (patch)
tree82448d629f04e58590a0adb08270070e431683ed
parentfe4825bfe27ba2dc43f7687ef2347667309003c2 (diff)
downloadaur-1719abb709632de25758d27343bcba91ae6ade70.tar.gz
Updated to v4.2.1
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD17
2 files changed, 19 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 405b77a895a5..2842ef475a97 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = tvheadend
pkgdesc = TV streaming server for Linux
- pkgver = 4.0.10
+ pkgver = 4.2.1
pkgrel = 1
url = https://tvheadend.org/projects/tvheadend
install = tvheadend.install
@@ -13,18 +13,20 @@ pkgbase = tvheadend
license = GPL3
makedepends = git
makedepends = wget
- makedepends = python2
+ makedepends = python
depends = avahi
depends = linuxtv-dvb-apps
- depends = ffmpeg2.8
+ depends = ffmpeg
depends = uriparser
+ depends = openssl
+ depends = tar
optdepends = xmltv: For an alternative source of programme listings
optdepends = libiconv: For conversion of character encodings
provides = tvheadend
conflicts = tvheadend-git
- source = https://github.com/tvheadend/tvheadend/archive/v4.0.10.tar.gz
+ source = https://github.com/tvheadend/tvheadend/archive/v4.2.1.tar.gz
source = tvheadend.service
- sha512sums = 419d3be0d6f9d41925d0185eae04d321efe25d756c6b033d91a363b3c150516a0d47c01adab9ac3148ae9463be2733f100a1779f3d9dd458c2e575e3fac3ce16
+ sha512sums = ef5e1995a89a1f375e467c8dcc325fcfc3d4a00723e028c10e8ebe4820bf6e977bfb404c994eabcdcf57ff27ee28f24b792aa377bb8c2b9c1796bcb65e50c19e
sha512sums = 456084a08ce0e02a4a32d67a8a7937d45695cb4b08b29297ead8a7e9d2a92963335f653f56d4c9346f4b2729868408fafbcd4caebf9fc8cdaa90171514cf4a57
pkgname = tvheadend
diff --git a/PKGBUILD b/PKGBUILD
index 1da6cef8aaae..19b6f509c88e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,14 +3,14 @@
pkgname=tvheadend
-pkgver=4.0.10
+pkgver=4.2.1
pkgrel=1
pkgdesc="TV streaming server for Linux"
arch=('i686' 'x86_64' 'arm' 'armv6h' 'armv7h' 'aarch64')
url="https://tvheadend.org/projects/tvheadend"
license=('GPL3')
-depends=('avahi' 'linuxtv-dvb-apps' 'ffmpeg2.8' 'uriparser')
-makedepends=('git' 'wget' 'python2')
+depends=('avahi' 'linuxtv-dvb-apps' 'ffmpeg' 'uriparser' 'openssl' 'tar')
+makedepends=('git' 'wget' 'python')
optdepends=('xmltv: For an alternative source of programme listings'
'libiconv: For conversion of character encodings')
provides=('tvheadend')
@@ -20,12 +20,19 @@ install=tvheadend.install
source=("https://github.com/tvheadend/tvheadend/archive/v$pkgver.tar.gz"
'tvheadend.service'
)
-sha512sums=('419d3be0d6f9d41925d0185eae04d321efe25d756c6b033d91a363b3c150516a0d47c01adab9ac3148ae9463be2733f100a1779f3d9dd458c2e575e3fac3ce16'
+sha512sums=('ef5e1995a89a1f375e467c8dcc325fcfc3d4a00723e028c10e8ebe4820bf6e977bfb404c994eabcdcf57ff27ee28f24b792aa377bb8c2b9c1796bcb65e50c19e'
'456084a08ce0e02a4a32d67a8a7937d45695cb4b08b29297ead8a7e9d2a92963335f653f56d4c9346f4b2729868408fafbcd4caebf9fc8cdaa90171514cf4a57')
prepare() {
cd ${srcdir}/${pkgname}-${pkgver}
- env PKG_CONFIG_PATH=/usr/lib/ffmpeg2.8/pkgconfig ./configure --prefix=/usr --python=python2
+ ./configure --prefix=/usr --python=python3 \
+ --disable-ffmpeg_static \
+ --disable-libx264_static \
+ --disable-libx265_static \
+ --disable-libvpx_static \
+ --disable-libtheora_static \
+ --disable-libvorbis_static \
+ --disable-libfdkaac_static
}
build() {