summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLouis Tim Larsen2023-05-15 22:45:17 +0200
committerLouis Tim Larsen2023-05-15 22:45:17 +0200
commit5215654a3f96f5428fe39f0ecc9cde835f9b5aa0 (patch)
treedbce09b808ca0a41eb0ab9f1e244dd855dd01ae7
parent70fac5d0cf56c0dafb86701685fd09995a3ef437 (diff)
downloadaur-5215654a3f96f5428fe39f0ecc9cde835f9b5aa0.tar.gz
Ignore use-after-free error at build time,libhdhomerun bumped to v. 20180327
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD12
-rw-r--r--libhdhomerun-20180327.patch15
3 files changed, 27 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c979397d86db..97a6178dd18a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = tvheadend
pkgdesc = TV streaming server for Linux
pkgver = 4.2.8
- pkgrel = 4
+ pkgrel = 5
url = https://tvheadend.org/projects/tvheadend
install = tvheadend.install
arch = i686
@@ -27,9 +27,10 @@ pkgbase = tvheadend
source = https://github.com/tvheadend/tvheadend/archive/v4.2.8.tar.gz
source = tvheadend-service.patch
source = tvheadend-4.2.8-fno-common.patch
+ source = libhdhomerun-20180327.patch
sha256sums = 1aef889373d5fad2a7bd2f139156d4d5e34a64b6d38b87b868a2df415f01f7ad
sha256sums = 23897afe6a6aa1382d0d37bf2c38bd4d04deabcb2bcc1f966b57323ffdc23f2c
sha256sums = 79a6f04859050830f2b0a8f3c025841627d8ab91fe2f5f73109cd72b02bb4ea8
+ sha256sums = 6c03e7c6cc0d5af1053bf428b004886fcbcd658a9e59a504aa028137de1f0343
pkgname = tvheadend
-
diff --git a/PKGBUILD b/PKGBUILD
index 5a45b9fcdabb..902d1b77b387 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,10 @@
-# Maintainer: Alex Mekkering <amekkering at gmail dot com>
+# Maintainer: Louis Tim Larsen <louis(a)louis.dk>, Alex Mekkering <amekkering at gmail dot com>
# Contributor: Bjoern Franke <bjo@nord-west.org>
pkgname=tvheadend
pkgver=4.2.8
-pkgrel=4
+pkgrel=5
pkgdesc="TV streaming server for Linux"
arch=('i686' 'x86_64' 'arm' 'armv6h' 'armv7h' 'aarch64')
url="https://tvheadend.org/projects/tvheadend"
@@ -22,10 +22,12 @@ install=tvheadend.install
source=("https://github.com/tvheadend/tvheadend/archive/v$pkgver.tar.gz"
"tvheadend-service.patch"
"tvheadend-4.2.8-fno-common.patch"
+ "libhdhomerun-20180327.patch"
)
sha256sums=('1aef889373d5fad2a7bd2f139156d4d5e34a64b6d38b87b868a2df415f01f7ad'
'23897afe6a6aa1382d0d37bf2c38bd4d04deabcb2bcc1f966b57323ffdc23f2c'
- '79a6f04859050830f2b0a8f3c025841627d8ab91fe2f5f73109cd72b02bb4ea8')
+ '79a6f04859050830f2b0a8f3c025841627d8ab91fe2f5f73109cd72b02bb4ea8'
+ '6c03e7c6cc0d5af1053bf428b004886fcbcd658a9e59a504aa028137de1f0343')
prepare() {
cd "${srcdir}/${pkgname}-${pkgver}"
@@ -36,6 +38,9 @@ prepare() {
# Fix building with -fno-common (default from GCC 10)
patch -p1 -i "${srcdir}/tvheadend-4.2.8-fno-common.patch"
+ # Change libhdhomerun source from 20171221 to 20180327
+ patch -i "${srcdir}/libhdhomerun-20180327.patch"
+
# detect libavresample and prepare for using it
uselibav=""
if [ -f /usr/include/libavresample/avresample.h ]; then
@@ -58,6 +63,7 @@ prepare() {
}
build() {
+ CFLAGS="$CFLAGS -Wno-error=implicit-function-declaration -Wno-error=use-after-free"
cd "${srcdir}/${pkgname}-${pkgver}"
make
}
diff --git a/libhdhomerun-20180327.patch b/libhdhomerun-20180327.patch
new file mode 100644
index 000000000000..01254461e8cc
--- /dev/null
+++ b/libhdhomerun-20180327.patch
@@ -0,0 +1,15 @@
+--- a/src/Makefile.hdhomerun 2023-05-15 20:34:44.891608958 +0200
++++ b/src/Makefile.hdhomerun 2023-05-15 20:35:49.068718439 +0200
+@@ -32,10 +32,10 @@
+ # Upstream Packages
+ # ###########################################################################
+
+-LIBHDHR = libhdhomerun_20171221
++LIBHDHR = libhdhomerun_20180327
+ LIBHDHR_TB = $(LIBHDHR).tgz
+ LIBHDHR_URL = http://download.silicondust.com/hdhomerun/$(LIBHDHR_TB)
+-LIBHDHR_SHA1 = 6b019728eadea3af7a5686ed5ba44e970bca7365
++LIBHDHR_SHA1 = a6b0ce4a8b5ea103a9de2d1d9cada4b36e13c74f
+
+ # ###########################################################################
+ # Library Config