summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBjoern Franke2015-06-08 20:59:13 +0200
committerBjoern Franke2015-06-08 20:59:13 +0200
commitb94d9b8cdebb322abcf3f59f05dff854dacc99e5 (patch)
tree2544f87fdbcc70d3ee3e6d1441fb605086bb324b
downloadaur-b94d9b8cdebb322abcf3f59f05dff854dacc99e5.tar.gz
Initial import
-rw-r--r--.SRCINFO31
-rw-r--r--PKGBUILD38
-rw-r--r--tvheadend.install24
-rw-r--r--tvheadend.service14
4 files changed, 107 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..03593a0453be
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,31 @@
+pkgbase = tvheadend
+ pkgdesc = TV streaming server for Linux
+ pkgver = 4.0.4
+ pkgrel = 1
+ url = https://tvheadend.org/projects/tvheadend
+ install = tvheadend.install
+ arch = i686
+ arch = x86_64
+ arch = arm
+ arch = armv6h
+ arch = armv7h
+ license = GPL3
+ makedepends = git
+ depends = avahi
+ depends = openssl
+ depends = python2
+ depends = ffmpeg
+ optdepends = xmltv: For an alternative source of programme listings
+ provides = tvheadend
+ conflicts = tvheadend
+ conflicts = hts-tvheadend
+ conflicts = hts-tvheadend-svn
+ conflicts = hts-tvheadend-git
+ conflicts = tvheadend-git
+ source = https://github.com/tvheadend/tvheadend/archive/v4.0.4.tar.gz
+ source = tvheadend.service
+ sha512sums = 2ef90f7a183905df40f6cd6852d26cce79ec420fa7eca299730f6f923e007e5930c5dada4c61a0a06dc1a71d8b7cb4a3d8a30b608f89ede1a1d378a2ec6ee83e
+ sha512sums = 456084a08ce0e02a4a32d67a8a7937d45695cb4b08b29297ead8a7e9d2a92963335f653f56d4c9346f4b2729868408fafbcd4caebf9fc8cdaa90171514cf4a57
+
+pkgname = tvheadend
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1434188132f2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Bjoern Franke <bjo@nord-west.org>
+
+pkgname=tvheadend
+
+pkgver=4.0.4
+pkgrel=1
+pkgdesc="TV streaming server for Linux"
+arch=('i686' 'x86_64' 'arm' 'armv6h' 'armv7h')
+url="https://tvheadend.org/projects/tvheadend"
+license=('GPL3')
+depends=('avahi' 'openssl' 'python2' 'ffmpeg')
+makedepends=('git')
+optdepends=('xmltv: For an alternative source of programme listings')
+provides=('tvheadend')
+conflicts=('tvheadend' 'hts-tvheadend' 'hts-tvheadend-svn' 'hts-tvheadend-git' 'tvheadend-git')
+install=tvheadend.install
+
+source=("https://github.com/tvheadend/tvheadend/archive/v$pkgver.tar.gz"
+ 'tvheadend.service')
+
+sha512sums=('2ef90f7a183905df40f6cd6852d26cce79ec420fa7eca299730f6f923e007e5930c5dada4c61a0a06dc1a71d8b7cb4a3d8a30b608f89ede1a1d378a2ec6ee83e'
+ '456084a08ce0e02a4a32d67a8a7937d45695cb4b08b29297ead8a7e9d2a92963335f653f56d4c9346f4b2729868408fafbcd4caebf9fc8cdaa90171514cf4a57')
+
+prepare() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ ./configure --prefix=/usr --mandir=/usr/share/man/man1 --python=python2 --r$
+}
+
+build() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ make
+}
+
+package() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ make DESTDIR="$pkgdir/" install
+ install -D -m 644 "$srcdir/tvheadend.service" "$pkgdir/usr/lib/systemd/system/tvheadend.service"
+}
diff --git a/tvheadend.install b/tvheadend.install
new file mode 100644
index 000000000000..f2446007e519
--- /dev/null
+++ b/tvheadend.install
@@ -0,0 +1,24 @@
+HTS_USER=hts
+HTS_UID=1337
+HTS_GROUP=video
+
+post_install() {
+ if ! getent passwd $HTS_USER &> /dev/null; then
+ useradd -u $HTS_UID -g $HTS_GROUP -m -s /bin/false $HTS_USER &> /dev/null
+ passwd -l $HTS_USER &> /dev/null
+ echo " ==> User '$HTS_USER' created"
+ fi
+
+cat << 'EOM'
+ ==> All configuration is maintained through the web interface:
+ ==>
+ ==> http://localhost:9981/
+ ==>
+ ==> Default login without username/password.
+EOM
+}
+
+post_remove() {
+ userdel $HTS_USER &> /dev/null
+ echo " ==> User '$HTS_USER' removed"
+}
diff --git a/tvheadend.service b/tvheadend.service
new file mode 100644
index 000000000000..5754f27d20a0
--- /dev/null
+++ b/tvheadend.service
@@ -0,0 +1,14 @@
+[Unit]
+Description=tvheadend
+After=tmp.mount network.target
+
+[Service]
+Type=forking
+PIDFile=/run/tvheadend.pid
+ExecStart=/usr/bin/tvheadend -f -p /run/tvheadend.pid -C -u hts -g video
+ExecStop=/usr/bin/rm /run/tvheadend.pid
+Restart=always
+RestartSec=5
+
+[Install]
+WantedBy=multi-user.target