summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrett2021-11-23 08:09:02 +0000
committerBrett2021-11-23 08:09:02 +0000
commit5db15b2801fc3d8b34be6b49de0dda875c93bdb0 (patch)
tree66f4d804cfd0091cb62740226d9573bdfda97be8
parenta28a6bebb2cc1a495c5349095098f4a1b204bb2b (diff)
downloadaur-txt.tar.gz
Changed source
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD12
2 files changed, 10 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ac16a1a572d2..bb76ede27fb4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,11 @@
pkgbase = txt
pkgdesc = A shitty text editor written in C99
pkgver = 1.0.0
- pkgrel = 1
- url = https://github.com/ItzAfroBoy/txt.git
+ pkgrel = 2
+ url = https://github.com/ItzAfroBoy/txt
arch = any
license = GPL3
- source = git+https://github.com/ItzAfroBoy/txt.git
- md5sums = SKIP
+ source = txt-1.0.0.tar.gz::https://github.com/ItzAfroBoy/txt/archive/refs/tags/1.0.0.tar.gz
+ md5sums = 811fd6c6987c46c1d92640eb6cbea33c
pkgname = txt
diff --git a/PKGBUILD b/PKGBUILD
index 0ebe337229fb..24575f22c559 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,21 @@
# Maintainer: Brett Lee (ItzAfroBoy) <me.caramackid@gmail.com>
pkgname=txt
pkgver=1.0.0
-pkgrel=1
+pkgrel=2
pkgdesc="A shitty text editor written in C99"
arch=('any')
-url="https://github.com/ItzAfroBoy/txt.git"
+url="https://github.com/ItzAfroBoy/txt"
license=('GPL3')
-source=("git+$url")
-md5sums=('SKIP')
+source=("$pkgname-$pkgver.tar.gz::$url/archive/refs/tags/$pkgver.tar.gz")
+md5sums=('811fd6c6987c46c1d92640eb6cbea33c')
build() {
- cd "${pkgname}"
+ cd "${pkgname}-${pkgver}"
make
}
package() {
- cd "${pkgname}"
+ cd "${pkgname}-${pkgver}"
install -Dm 644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
install -Dm 644 README.md "${pkgdir}/usr/share/doc/${pkgname}/README.md"
mkdir -p "${pkgdir}/usr/bin"