summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonathan Duck2018-05-31 17:43:56 -0700
committerJonathan Duck2018-05-31 17:43:56 -0700
commit2e0b83ca5d7c9ec7ba559eaa4f46e72fe1475b54 (patch)
tree03c31bf2bb86b557768511ebdf23c9311b823b93
parent4afcc19c95ab1ba066d64fb948dbea1b033f4c9d (diff)
downloadaur-2e0b83ca5d7c9ec7ba559eaa4f46e72fe1475b54.tar.gz
Update to version 0.9.53
-rw-r--r--.SRCINFO6
-rw-r--r--Makefile6
-rw-r--r--PKGBUILD4
3 files changed, 11 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7ab63edcde9f..d7b1a117dd9a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = typora
pkgdesc = Typora will give you a seamless experience as both a reader and a writer.
- pkgver = 0.9.52
+ pkgver = 0.9.53
pkgrel = 1
url = https://typora.io/
arch = x86_64
@@ -8,8 +8,8 @@ pkgbase = typora
depends = gconf
depends = libxss
optdepends = noto-fonts-emoji: Or some other emoji font to see emojis
- source = https://typora.io/./linux/typora_0.9.52_amd64.deb
- md5sums = 7301eb4066e3eb1d61768e0288638aba
+ source = https://typora.io/./linux/typora_0.9.53_amd64.deb
+ md5sums = 7bf938aa11cc6b8d3dca442e673b057b
pkgname = typora
diff --git a/Makefile b/Makefile
index 61ab6e7d1aa4..468303fdb7c2 100644
--- a/Makefile
+++ b/Makefile
@@ -23,3 +23,9 @@ versions:
# This will remove the files downloaded and created in the build process
clean:
rm -rf pkg src typora_*.deb typora-*.pkg.tar
+
+publish:
+ git add .
+ git commit -m "Update to version $(shell $(MAKE) versions | tail -n 1)"
+ git push
+ git push aur master
diff --git a/PKGBUILD b/PKGBUILD
index 45c951d66076..12be3c939e87 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Jonathan Duck <duckbrain30@gmail.com>
pkgname=typora
-pkgver=0.9.52
+pkgver=0.9.53
pkgrel=1
pkgdesc="Typora will give you a seamless experience as both a reader and a writer."
arch=('x86_64')
@@ -10,7 +10,7 @@ url="https://typora.io/"
depends=('gconf' 'libxss')
optdepends=('noto-fonts-emoji: Or some other emoji font to see emojis')
source=("https://typora.io/./linux/$filename")
-md5sums=('7301eb4066e3eb1d61768e0288638aba')
+md5sums=('7bf938aa11cc6b8d3dca442e673b057b')
package() {
bsdtar -xf data.tar.xz -C "$pkgdir/"