summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonathan Duck2016-10-10 07:49:40 -0700
committerJonathan Duck2016-10-10 07:49:40 -0700
commitd64be5239b825f0c7209f48d83ce629952c4e2e3 (patch)
tree700d07ee4e8e310c5bc915051c84e9b7cb7c4f26
parentf53670e1f4c1eb4d5db58d4f0a2b456475ddf31e (diff)
downloadaur-d64be5239b825f0c7209f48d83ce629952c4e2e3.tar.gz
Added gconf dependency and fixed permissions to make only directories
additionally executable
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD7
2 files changed, 6 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b9ab47077375..b95a083c0ccd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,11 @@
pkgbase = typora
pkgdesc = Typora will give you a seamless experience as both a reader and a writer.
pkgver = 0.9.20
- pkgrel = 1
+ pkgrel = 2
url = https://typora.io/
arch = x86_64
license = custom:"Copyright (c) 2014 GitHub Inc."
+ depends = gconf
source = https://typora.io/./linux/typora_0.9.20_amd64.deb
md5sums = bfe7b4f0c12b1c5d8d35882407f6ec97
diff --git a/PKGBUILD b/PKGBUILD
index 5456affa1b55..c0e21267f256 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,18 @@
# Maintainer: Jonathan Duck <duckbrain30@gmail.com>
pkgname=typora
pkgver=0.9.20
-pkgrel=1
+pkgrel=2
pkgdesc="Typora will give you a seamless experience as both a reader and a writer."
arch=('x86_64')
filename="${pkgname}_${pkgver}_amd64.deb"
license=('custom:"Copyright (c) 2014 GitHub Inc."')
url="https://typora.io/"
+depends=('gconf')
source=("https://typora.io/./linux/$filename")
md5sums=('bfe7b4f0c12b1c5d8d35882407f6ec97')
package() {
bsdtar -xf data.tar.xz -C "$pkgdir/"
- rm -rf "${pkgdir}"/usr/share/lintian/
- chmod -R 755 "$pkgdir"
+ rm -rf "$pkgdir"/usr/share/lintian/
+ find "$pkgdir" -type d -exec chmod 755 {} \;
}