summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Down2023-11-09 15:17:55 +0000
committerChris Down2023-11-09 15:17:55 +0000
commit7ff8efeb1c1c57bbc1e92ba19f594293ca33840d (patch)
tree43485d16870b9180bd2e320b5dc824cada32ef56
parent0e3e08a1de0d990054b9ea7943eec5a981ce3444 (diff)
downloadaur-tzupdate.tar.gz
upgpkg: tzupdate 3.1.0-1
upstream release
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD23
2 files changed, 21 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9bb9ef84413a..2053bb569098 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,12 @@
pkgbase = tzupdate
pkgdesc = Set the system timezone based on IP geolocation
- pkgver = 2.1.0
+ pkgver = 3.1.0
pkgrel = 1
- url = http://github.com/cdown/tzupdate
- arch = any
- license = Public Domain
- depends = python
- depends = python-setuptools
- source = https://github.com/cdown/tzupdate/archive/2.1.0.zip
- md5sums = d1bfe48af64922eca1553d4f553d74cc
+ url = https://github.com/cdown/tzupdate
+ arch = x86_64
+ license = MIT
+ makedepends = cargo
+ source = https://github.com/cdown/tzupdate/archive/refs/tags/3.1.0.tar.gz
+ sha256sums = aebf678afd261852bd3ebf4689a9a7382c3e4e43a92864b77cbee2d26ec62e22
pkgname = tzupdate
diff --git a/PKGBUILD b/PKGBUILD
index 82e30a618647..377d4b0ecb78 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,22 @@
# Maintainer: Chris Down <chris@chrisdown.name>
pkgname=tzupdate
-pkgver=2.1.0
+pkgver=3.1.0
pkgrel=1
pkgdesc='Set the system timezone based on IP geolocation'
-url=http://github.com/cdown/tzupdate
-arch=(any)
-license=('Public Domain')
-depends=(python python-setuptools)
-source=("https://github.com/cdown/tzupdate/archive/${pkgver}.zip")
-md5sums=('d1bfe48af64922eca1553d4f553d74cc')
+url=https://github.com/cdown/tzupdate
+arch=('x86_64')
+license=('MIT')
+makedepends=('cargo')
+source=("$url/archive/refs/tags/$pkgver.tar.gz")
+sha256sums=('aebf678afd261852bd3ebf4689a9a7382c3e4e43a92864b77cbee2d26ec62e22')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ cargo build --release --locked
+}
package() {
- cd "${srcdir?}/$pkgname-$pkgver" || return 1
- python setup.py install --root="${pkgdir?}"
+ cd "$srcdir/$pkgname-$pkgver"
+ cargo install --no-track --locked --root "$pkgdir/usr" --path .
}