summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorotreblan2020-08-29 16:38:33 -0500
committerotreblan2020-08-29 16:38:33 -0500
commit6bd7f4249036469e14bdefcf6264e7190a07e4f0 (patch)
treea5df45dd2d9a8095eba5cd13820446fcba19047c
downloadaur-uberswitch-git.tar.gz
First commit
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore16
-rw-r--r--PKGBUILD35
3 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..aea3fbdc8d21
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = uberswitch-git
+ pkgdesc = A header-only, unobtrusive, almighty alternative to the C++ switch statement that looks just like the original.
+ pkgver = r39.1a192a5
+ pkgrel = 1
+ url = https://github.com/falemagn/uberswitch
+ arch = x86_64
+ license = Unlicense
+ makedepends = git
+ provides = uberswitch
+ conflicts = uberswitch
+ source = uberswitch-git::git+https://github.com/falemagn/uberswitch.git
+ sha256sums = SKIP
+
+pkgname = uberswitch-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..c8b641539322
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,16 @@
+# create by https://github.com/iamcco/coc-gitignore (Sat Aug 29 2020 16:38:16 GMT-0500 (hora estándar de Perú))
+# ArchLinuxPackages.gitignore:
+*.tar
+*.tar.*
+*.jar
+*.exe
+*.msi
+*.zip
+*.tgz
+*.log
+*.log.*
+*.sig
+
+pkg/
+src/
+*-git/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..efe644034695
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Otreblan <otreblain@gmail.com>
+
+pkgname=uberswitch-git
+pkgver=r39.1a192a5
+pkgrel=1
+epoch=
+pkgdesc="A header-only, unobtrusive, almighty alternative to the C++ switch statement that looks just like the original."
+arch=('x86_64')
+url="https://github.com/falemagn/uberswitch"
+license=('Unlicense')
+groups=()
+depends=()
+makedepends=('git')
+checkdepends=()
+optdepends=()
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=("$pkgname::git+$url.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$pkgname"
+
+ ( set -o pipefail
+ git describe --long 2>/dev/null | sed 's/^v-//;s/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+
+ mkdir -p "$pkgdir/usr/include"
+ mv include/${pkgname%-git} "$pkgdir/usr/include/${pkgname%-git}"
+}