summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBerin Aniesh2023-11-05 09:12:17 +0530
committerBerin Aniesh2023-11-05 09:12:17 +0530
commit9233590f378d1efb8780cad6a9e98b8287d69adf (patch)
tree852cb3fb527c0e5cc00efd9856412ae33b91fb3e
parentaa9d17548fa184bca1a11f9110ad51ec32245873 (diff)
downloadaur-ucf.tar.gz
add optional dependencies
-rw-r--r--PKGBUILD13
1 files changed, 13 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index abc67c085e21..5cc911678f03 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,6 +9,19 @@ arch=('x86_64')
url=https://github.com/berinaniesh/ucf
license=('MIT')
depends=('gcc-libs')
+optdepends=('black: python files'
+ 'clang-format: java, c, c++, json files'
+ 'cmake-format: cmake files'
+ 'go: go-fmt for go files'
+ 'ocamlformat: ocaml files'
+ 'prettier: html, md, js files'
+ 'rustfmt: rs files'
+ 'shfmt: sh, ebuild files'
+ 'stylish-haskell: hs files'
+ 'stylua: lua files'
+ 'taplo: toml files'
+ 'xmllint: xml files'
+ 'zig: zig fmt for zig files')
makedepends=('cargo')
provides=("${pkgname}")
options=('!lto')