summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnatol Pomozov2015-06-17 08:54:14 -0700
committerAnatol Pomozov2015-06-17 08:54:14 -0700
commit14425bb1e524bc0c85ecf8d1f4fa912094e606ee (patch)
tree47cd1a2f371ee8205067b60e8236ebe8f8d8784a
downloadaur-uefivars-git.tar.gz
Initial import
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD35
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7cba93ac0a46
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = uefivars-git
+ pkgdesc = A tool to populate UEFI Runtime Variables. Requires the kernel module efivars to be loaded.
+ pkgver = r1.1f22f91
+ pkgrel = 1
+ url = https://github.com/fpmurphy/Various/tree/master/uefivars-2.0
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ depends = efibootmgr
+ source = git://github.com/fpmurphy/Various
+ sha1sums = SKIP
+
+pkgname = uefivars-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..33a0bc2d7d21
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Anatol Pomozov <anatol.pomozov@gmail.com>
+# Contributor: Murtuza Akhtari <inxsible at gmail dot com>
+
+pkgname=uefivars-git
+pkgver=r1.1f22f91
+pkgrel=1
+pkgdesc='A tool to populate UEFI Runtime Variables. Requires the kernel module efivars to be loaded.'
+arch=(i686 x86_64)
+url='https://github.com/fpmurphy/Various/tree/master/uefivars-2.0'
+license=(GPL)
+depends=(efibootmgr)
+makedepends=(git)
+source=(git://github.com/fpmurphy/Various)
+sha1sums=('SKIP')
+
+pkgver() {
+ cd Various/uefivars-2.0
+ echo r$(git rev-list --count master .).$(git rev-parse --short master)
+}
+
+prepare() {
+ cd Various/uefivars-2.0
+ # uefivars-git does not respect CFLAGS, fix it
+ sed -e 's/CFLAGS = $(EXTRA_CFLAGS)/CFLAGS += $(EXTRA_CFLAGS)/' -i Makefile
+}
+
+build() {
+ cd Various/uefivars-2.0
+ make
+}
+
+package() {
+ cd Various/uefivars-2.0
+ install -D -m755 src/uefivars/uefivars "$pkgdir"/usr/bin/uefivars
+}