summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Runge2015-07-26 15:09:28 +0200
committerDavid Runge2015-07-26 15:09:28 +0200
commit510d8bf2e0b062a736371e045f54574a2cc93dd0 (patch)
tree017f4e327118f2c86ccc0892bb07a2d04a61e68e
parent1cd952ea1d79995372bf08412fea9cfe56c5948e (diff)
downloadaur-510d8bf2e0b062a736371e045f54574a2cc93dd0.tar.gz
PKGBUILD,.SRCINFO: Updating to post 0.1 release. Fixing dbus user session.
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD27
2 files changed, 21 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 579e89c0c6aa..16f733249cab 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = uenv-git
pkgdesc = Useful scripts, systemd timer/service units and their configuration
- pkgver = r30.cae71ea
- pkgrel = 1
+ pkgver = 0.1.r0.g82b0907
+ pkgrel = 3
url = https://sleepmap.de/projects/uenv
arch = any
license = GPL3
@@ -9,15 +9,16 @@ pkgbase = uenv-git
optdepends = autossh: For autotunnel (SSH tunnel)
optdepends = compton: For compton user service
optdepends = cpupower: For cpupower settings on linux-rt
- optdepends = glances: For monitoring user service
- optdepends = htop: For monitoring user service
- optdepends = jack: For profile based JACK user service
- optdepends = linux-rt: For cpupower and jack services
- optdepends = mpd: For mpd user service to connect to server profiles
- optdepends = pulseaudio: For pulseaudio user service
+ optdepends = glances: For monitoring user service (running in separate tmux environment)
+ optdepends = htop: For monitoring user service (running in separate tmux environment)
+ optdepends = irssi: For irssi in a separate tmux environment
+ optdepends = jack2: For profile based JACK user service
+ optdepends = linux-rt: For cpupower and JACK services
+ optdepends = mpd: For mpd user service connecting to server profiles
optdepends = rtorrent: For rtorrent user and system service
optdepends = tmux: For monitoring, rtorrent and tmux user services
optdepends = update-mirrorlist: For timed pacman mirrorlist updates
+ optdepends = weechat: For weechat in a separate tmux environment
provides = uenv
provides = postpone-screensaver
conflicts = uenv
diff --git a/PKGBUILD b/PKGBUILD
index 2bf4a33e911d..250f22315c40 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: David Runge <dave@sleepmap.de>
pkgname=uenv-git
-pkgver=r30.cae71ea
+pkgver=0.1.r0.g82b0907
_basename=uenv
-pkgrel=1
+pkgrel=3
pkgdesc="Useful scripts, systemd timer/service units and their configuration"
arch=('any')
url="https://sleepmap.de/projects/uenv"
@@ -14,15 +14,16 @@ optdepends=(
'autossh: For autotunnel (SSH tunnel)'\
'compton: For compton user service'\
'cpupower: For cpupower settings on linux-rt'\
- 'glances: For monitoring user service'\
- 'htop: For monitoring user service'\
- 'jack: For profile based JACK user service'\
- 'linux-rt: For cpupower and jack services'\
- 'mpd: For mpd user service to connect to server profiles'\
- 'pulseaudio: For pulseaudio user service'\
+ 'glances: For monitoring user service (running in separate tmux environment)'\
+ 'htop: For monitoring user service (running in separate tmux environment)'\
+ 'irssi: For irssi in a separate tmux environment'\
+ 'jack2: For profile based JACK user service'\
+ 'linux-rt: For cpupower and JACK services'\
+ 'mpd: For mpd user service connecting to server profiles'\
'rtorrent: For rtorrent user and system service'\
'tmux: For monitoring, rtorrent and tmux user services'\
- 'update-mirrorlist: For timed pacman mirrorlist updates'
+ 'update-mirrorlist: For timed pacman mirrorlist updates'\
+ 'weechat: For weechat in a separate tmux environment'
)
provides=('uenv' 'postpone-screensaver')
conflicts=('uenv' 'postpone-screensaver')
@@ -45,10 +46,7 @@ build() {
pkgver() {
cd "$srcdir/$_basename"
- ( set -o pipefail
- git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
- )
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
package() {
@@ -56,7 +54,7 @@ package() {
install -d ${pkgdir}/usr/lib/systemd/scripts/
install -Dm 755 scripts/* ${pkgdir}/usr/lib/systemd/scripts/
install -d ${pkgdir}/usr/lib/systemd/system/user@.service.d/
- install -Dm 644 system/user@.service.d/dbus.conf ${pkgdir}/usr/lib/systemd/system/
+ install -Dm 644 system/user@.service.d/dbus.conf ${pkgdir}/usr/lib/systemd/system/user@.service.d/
install -d ${pkgdir}/usr/lib/systemd/system/
install -Dm 644 system/{autotunnel@,cpupower-rt,rtorrent@,update-mirrorlist}.* ${pkgdir}/usr/lib/systemd/system/
install -d ${pkgdir}/usr/lib/systemd/user/
@@ -68,7 +66,6 @@ package() {
install -Dm 644 config/rtorrent@.conf ${pkgdir}/etc/default/rtorrent@.conf
install -Dm 644 config/autotunnel/example.conf ${pkgdir}/etc/autotunnel/example.conf
install -Dm 644 README.md ${pkgdir}/usr/share/doc/${_basename}/README.md
- install -Dm 644 LICENSE ${pkgdir}/usr/share/licenses/${_basename}/LICENSE
}
# vim:set ts=2 sw=2 et: