summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSam Bazley2020-06-14 17:47:16 +0100
committerSam Bazley2020-06-14 17:47:16 +0100
commit14bab1b6412cfdd09cb6ccfc67f3ef89f037ee24 (patch)
tree95602f31b12328908c0e798ceb4d500e55d35307
parentc6ffa2c53ab0a16b948978bb2632ee2be983b639 (diff)
downloadaur-ujson-git.tar.gz
Update to use new Makefile build system
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD13
2 files changed, 4 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8c4413013279..6f5937082790 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ujson-git
pkgdesc = Json library written in C
- pkgver = 20181227185838
+ pkgver = 20200614025758
pkgrel = 1
url = https://gitlab.com/Niflheimr/ujson
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index 495f9fcb86c1..a2f4ae72794f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
-#Maintainer: Sam Bazley <sambazley@protonmail.com>
+#Maintainer: Sam Bazley <sambazley@fastmail.com>
pkgname=ujson-git
-pkgver=20181227185838
+pkgver=20200614025758
pkgrel=1
pkgdesc="Json library written in C"
arch=("i686" "x86_64")
@@ -16,20 +16,13 @@ pkgver() {
git show -s --format=%ci HEAD | cut -d' ' -f1-2 | sed -r 's/[^0-9]//g'
}
-prepare() {
- cd "$srcdir/ujson"
- git submodule init
- git submodule update
-}
-
build() {
cd "$srcdir/ujson"
- cmake -DCMAKE_INSTALL_PREFIX="$pkgdir/usr" .
make
}
package() {
cd ujson
- make install
+ make DESTDIR="$pkgdir" PREFIX=/usr install
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}