summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLahfa Samy2023-07-28 01:38:04 +0200
committerLahfa Samy2023-07-28 01:38:04 +0200
commit5cc59ee94fa5daad160ee6d005bfce47b962fdef (patch)
treebe4bf6a3ec8fa8e635efd233fafbfafd80b72dad
parent58ea7bdfdcb3caff559b42abca25fbaf56b1a280 (diff)
downloadaur-unblob-git.tar.gz
Add source and use jefferson instead of python-jefferson
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD7
2 files changed, 7 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4c2ea48062da..b2db68307c21 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = unblob-git
pkgdesc = Extract files from any kind of container formats
- pkgver = 0.0.0.r1226.g639ec9a
+ pkgver = 0.0.0.r1228.g6b5e38a
pkgrel = 1
url = https://github.com/onekey-sec/unblob
arch = any
@@ -31,5 +31,7 @@ pkgbase = unblob-git
depends = python-ubi-reader
depends = python-treelib
depends = python-unblob-native
+ source = https://github.com/onekey-sec/unblob
+ sha256sums = SKIP
pkgname = unblob-git
diff --git a/PKGBUILD b/PKGBUILD
index e346047188b4..d949e313d28f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=unblob-git
_pkgname=${pkgname%-git}
-pkgver=0.0.0.r1226.g639ec9a
+pkgver=0.0.0.r1228.g6b5e38a
pkgrel=1
pkgdesc='Extract files from any kind of container formats'
arch=(any)
@@ -13,8 +13,8 @@ _py_deps=(arpy
click
cstruct
dissect.cstruct
- pyperscan # pyperscan replaces hyperscan (brings vectorscan too)
# see : https://github.com/onekey-sec/unblob/pull/411#issuecomment-1555961215
+ pyperscan # pyperscan replaces hyperscan (brings vectorscan too)
jefferson
lark-parser
lief
@@ -35,6 +35,8 @@ makedepends=(git
git-lfs
python-{build,installer,wheel}
python-poetry)
+source=("https://github.com/onekey-sec/unblob")
+sha256sums=('SKIP')
# git clone using source array
# Fails with git-lfs error
@@ -45,7 +47,6 @@ prepare() {
pkgver() {
cd "$_pkgname"
- git tag v0.0.0 1958a226e2ffe86262ddd5a8e8f87a0f98816cdf^
git describe --long --abbrev=7 --tags --match="v*" |
sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}