summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexandre ZANNI2024-02-15 15:53:28 +0100
committerAlexandre ZANNI2024-02-15 15:53:28 +0100
commit69f9518fd775013f91dc98f97f2e719cd3a545ef (patch)
tree9aa5cb3138db0b318aa2fed67b192e13076c238b
downloadaur-unidump.tar.gz
add unidump
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD26
3 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..43f759e446f7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = unidump
+ pkgdesc = hexdump for Unicode data.
+ pkgver = 1.1.2
+ pkgrel = 1
+ url = https://github.com/Codepoints/unidump
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python
+ conflicts = unidump-git
+ source = https://files.pythonhosted.org/packages/source/u/unidump/unidump-1.1.2.tar.gz
+ b2sums = d6daad3853702936f8c1020ac47eb52fbd36af45edf24f16b4344496a0869e7ad923a8c5fbf7165c71d8cbfe186d1c21631f9b58c54ead6be85591d929c6b62a
+
+pkgname = unidump
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..c396b125ae34
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.log
+unidump/
+*.zst
+*.gz \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..31b8e0aea0f8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: noraj <printf %s 'YWxleGFuZHJlLnphbm5pQGV1cm9wZS5jb20='|base64 -d>
+
+pkgname=unidump
+pkgver=1.1.2
+pkgrel=1
+pkgdesc='hexdump for Unicode data.'
+arch=('any')
+url='https://github.com/Codepoints/unidump'
+license=('MIT')
+depends=('python')
+makedepends=('python-setuptools')
+conflicts=('unidump-git')
+source=("https://files.pythonhosted.org/packages/source/${pkgname::1}/$pkgname/$pkgname-$pkgver.tar.gz")
+b2sums=('d6daad3853702936f8c1020ac47eb52fbd36af45edf24f16b4344496a0869e7ad923a8c5fbf7165c71d8cbfe186d1c21631f9b58c54ead6be85591d929c6b62a')
+
+build() {
+ cd "$pkgname-$pkgver"
+
+ python setup.py build
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+
+ python setup.py install --root="$pkgdir" --prefix=/usr -O1 --skip-build
+}