summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSergey Shatunov2020-02-06 21:45:32 +0800
committerSergey Shatunov2020-02-06 21:45:32 +0800
commitbe084bbfa93fc4f233714a131eacc6ce39b1a4e2 (patch)
tree7f2c4bada12749828da8a716706474f00d536b30
parent08e9e39c1ad4856f603719dd5791d0973f58e154 (diff)
downloadaur-unifed-arch-kernel.tar.gz
commit
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rwxr-xr-xuak12
3 files changed, 10 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7dff40329ee5..3c40704cc77c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = unifed-arch-kernel
pkgdesc = Generates unifed archlinux images using pacman power
pkgver = 0.0.6
- pkgrel = 1
+ pkgrel = 2
url = https://aur.archlinux.org/packages/unifed-arch-kernel/
arch = x86_64
license = GPL
@@ -13,7 +13,7 @@ pkgbase = unifed-arch-kernel
source = 75-sign-for-secure-boot.install
source = 95-unifed-arch-kernel-install.hook
md5sums = aa4f4f6300e708d6ee67b86414a6ede1
- md5sums = 3f5756050aaf4c0a13a11167682565a1
+ md5sums = e541a9ec2e9dc1bb2e83ac3fc5d3977c
md5sums = cf19112a5294756657e8e2e3ebf6226d
md5sums = c07998165fc01a2f5e7d453b51a7a024
md5sums = 9105de5ff7f384b1e48bdd4972b87917
diff --git a/PKGBUILD b/PKGBUILD
index 1725745741c4..7274e22744fe 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=('unifed-arch-kernel' 'unifed-arch-kernel-secure-boot')
pkgbase=unifed-arch-kernel
pkgver=0.0.6
-pkgrel=1
+pkgrel=2
pkgdesc='Generates unifed archlinux images using pacman power'
arch=(x86_64)
url='https://aur.archlinux.org/packages/unifed-arch-kernel/'
@@ -16,7 +16,7 @@ source=('uak-script'
'75-sign-for-secure-boot.install'
'95-unifed-arch-kernel-install.hook')
md5sums=('aa4f4f6300e708d6ee67b86414a6ede1'
- '3f5756050aaf4c0a13a11167682565a1'
+ 'e541a9ec2e9dc1bb2e83ac3fc5d3977c'
'cf19112a5294756657e8e2e3ebf6226d'
'c07998165fc01a2f5e7d453b51a7a024'
'9105de5ff7f384b1e48bdd4972b87917'
diff --git a/uak b/uak
index 3dd96a832106..6bfddac7d1e3 100755
--- a/uak
+++ b/uak
@@ -102,13 +102,13 @@ case "$COMMAND" in
if [[ ! $KERNEL_VERSION ]] || [[ ! "$KERNEL_IMAGE" ]]; then
die 1 "Not enough arguments"
fi
-
+
if [[ ! -f "$KERNEL_IMAGE" ]]; then
die 2 "Kernel image '${KERNEL_IMAGE}' not a file"
fi
-
+
shift 3
-
+
EFISTUB_IMAGE=$(mktemp)
EFISTUB_INSTALL_PATH="$UAK_ESP_TARGET/$ID-$KERNEL_VERSION.efi"
;;
@@ -116,13 +116,13 @@ case "$COMMAND" in
check_root
KERNEL_VERSION="$2"
-
+
if [[ ! $KERNEL_VERSION ]]; then
die 1 "Not enough arguments"
fi
shift 2
-
+
EFISTUB_INSTALL_PATH="$UAK_ESP_TARGET/$ID-$KERNEL_VERSION.efi"
;;
regenerate)
@@ -151,7 +151,7 @@ for plugin in "${PLUGINS[@]}"; do
done
-if [[ "$COMMAND" == "add" ]]; then
+if [[ "$COMMAND" == "install" ]]; then
if [[ -f "$EFISTUB_IMAGE" ]]; then
install -DT "$EFISTUB_IMAGE" "$EFISTUB_INSTALL_PATH" || warning "Unable to install image at $EFISTUB_INSTALL_PATH"
else