summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlvlrk2023-08-16 18:55:41 -0500
committerlvlrk2023-08-16 18:55:41 -0500
commit0d62ba3fd2d082bff28614b3fdfbeb72f936942e (patch)
tree904ba43a734f1ca1d1d7337723b71ec664b12a7b
downloadaur-unpac.tar.gz
initial
-rw-r--r--.INSTALL3
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD36
-rw-r--r--unpac-1.5.tar.gzbin0 -> 12559 bytes
4 files changed, 51 insertions, 0 deletions
diff --git a/.INSTALL b/.INSTALL
new file mode 100644
index 000000000000..fe5d17a98ca8
--- /dev/null
+++ b/.INSTALL
@@ -0,0 +1,3 @@
+pre_remove() {
+ rm -rf /bin/unpac /lib/libunpac.so /usr/include/unpac
+}
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1e59745b2cbd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = unpac
+ pkgdesc = An epic Namco Museum Remix modding tool
+ pkgver = 1.5
+ pkgrel = 1
+ url = https://github.com/lvlrk/unpac
+ install = .INSTALL
+ arch = x86_64
+ license = GPL
+ source = unpac-1.5.tar.gz
+ md5sums = 24cc7d97ed8e27140c88e0b450d5d0d9
+
+pkgname = unpac
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cad7b2e154d2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Devin Hill lvlrk4u@proton.me
+pkgname=unpac
+pkgver=1.5
+pkgrel=1
+epoch=
+pkgdesc="An epic Namco Museum Remix modding tool"
+arch=('x86_64')
+url="https://github.com/lvlrk/unpac"
+license=('GPL')
+groups=()
+depends=()
+makedepends=()
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=.INSTALL
+changelog=
+source=("$pkgname-$pkgver.tar.gz")
+noextract=()
+md5sums=(24cc7d97ed8e27140c88e0b450d5d0d9)
+validpgpkeys=()
+
+build() {
+ cd "$pkgname-$pkgver"
+ pwd
+ make clean all
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ sudo make DESTDIR="$pkgdir/" install install-lib
+}
diff --git a/unpac-1.5.tar.gz b/unpac-1.5.tar.gz
new file mode 100644
index 000000000000..5ffcbcfde5d8
--- /dev/null
+++ b/unpac-1.5.tar.gz
Binary files differ