summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNeko-san2022-07-07 14:15:38 -0500
committerNeko-san2022-07-07 14:15:38 -0500
commit24cdbb977b21f2ef07a5415ad389bd2d13adfba9 (patch)
tree685da95d65f7ec8f6d8a702a16d7572c316266c1
parentdb25a058112610f2e15ade1925b083e7ae79aa1f (diff)
downloadaur-24cdbb977b21f2ef07a5415ad389bd2d13adfba9.tar.gz
Added the checksum for the pacman hook and specified it as a optdepend
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD9
-rw-r--r--unreal-engine-4-pacman-cache.hook1
3 files changed, 11 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 40d89fe228d3..ecd43c006928 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = unreal-engine-4
pkgdesc = A 3D game engine by Epic Games which can be used non-commercially for free.
pkgver = 4.27
- pkgrel = 1
+ pkgrel = 0
url = https://www.unrealengine.com/
arch = x86_64
arch = x86_64_v2
@@ -23,13 +23,16 @@ pkgbase = unreal-engine-4
optdepends = codelite: IDE for projects
optdepends = kdevelop: IDE for projects
optdepends = clion: IDE for projects
+ optdepends = pacman-contrib: for the paccache cleaning hook
options = !strip
options = staticlibs
source = com.unrealengine.UE4Editor.desktop
source = clang_path_fix.patch
source = ccache_executor.patch
+ source = unreal-engine-4-pacman-cache.hook
sha256sums = 15e9f9d8dc8bd8513f6a5eca990e2aab21fd38724ad57d213b06a6610a951d58
sha256sums = 960c5a100e0c3732f3c73fb645d3989d39acf4576d74615bbef38ebeee008b90
sha256sums = 33982486f7fafac35a33dfa37c85cfba8543aa78b5fe13c395d9cccf691ef4b3
+ sha256sums = df4687c3bc54dbac3c1589e6104b41c5cba17863f447dc919677ad3a240528f3
pkgname = unreal-engine-4
diff --git a/PKGBUILD b/PKGBUILD
index beb8604004bd..4611d3bdb62e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -15,14 +15,17 @@ optdepends=('qt5-base: qmake build system for projects'
'qtcreator: IDE for projects'
'codelite: IDE for projects'
'kdevelop: IDE for projects'
- 'clion: IDE for projects')
+ 'clion: IDE for projects'
+ 'pacman-contrib: for the paccache cleaning hook')
license=('custom:UnrealEngine')
source=('com.unrealengine.UE4Editor.desktop'
'clang_path_fix.patch'
- 'ccache_executor.patch')
+ 'ccache_executor.patch'
+ 'unreal-engine-4-pacman-cache.hook')
sha256sums=('15e9f9d8dc8bd8513f6a5eca990e2aab21fd38724ad57d213b06a6610a951d58'
'960c5a100e0c3732f3c73fb645d3989d39acf4576d74615bbef38ebeee008b90'
- '33982486f7fafac35a33dfa37c85cfba8543aa78b5fe13c395d9cccf691ef4b3')
+ '33982486f7fafac35a33dfa37c85cfba8543aa78b5fe13c395d9cccf691ef4b3'
+ 'df4687c3bc54dbac3c1589e6104b41c5cba17863f447dc919677ad3a240528f3')
# Not sure if compiling Unreal with LTO is legal? Lot's of different proprietary software goes into Unreal
options=('!strip' 'staticlibs') # Package is 3 Gib smaller with "strip" but it takes a long time and generates many warnings
diff --git a/unreal-engine-4-pacman-cache.hook b/unreal-engine-4-pacman-cache.hook
index 18517db0e90c..5a9b250d7977 100644
--- a/unreal-engine-4-pacman-cache.hook
+++ b/unreal-engine-4-pacman-cache.hook
@@ -6,5 +6,6 @@ Target = unreal-engine-4
[Action]
Description = Leaving only one Unreal Engine 4 package in cache to save storage space...
+Depends = pacman-contrib
When = PostTransaction
Exec = /bin/sh -c '/usr/bin/paccache -rvk1 unreal-engine-4'