summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNeko-san2022-11-20 14:39:18 -0600
committerNeko-san2022-11-20 14:39:18 -0600
commit3935373220d02f00813cade1c3f1aff4bf5b847d (patch)
treea03f3bec578e6795a9f0764e023d86461ee76e58
parentf90585cc16819b1972cfdbcbc69eda17be830944 (diff)
downloadaur-3935373220d02f00813cade1c3f1aff4bf5b847d.tar.gz
Updated unreal-engine-4.sh
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD2
-rwxr-xr-xunreal-engine-4.sh4
3 files changed, 4 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9c808e8d8261..e934ef841493 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -40,7 +40,7 @@ pkgbase = unreal-engine-4
source = clang_path_fix.patch
source = ccache_executor.patch
source = unreal-engine-4-pacman-cache.hook
- sha256sums = c8771291d5ca38696686b06ad7affab496f5ab1b9c5570bd104c9542905a404e
+ sha256sums = 4180b39fe5ec3aa64a4b22171ddc677670190b011dc5a9457d0387959ec60e54
sha256sums = c04c03b2c5c933b7eb1af283d607934ad95fd57f44d62b83719061b555a85dca
sha256sums = 960c5a100e0c3732f3c73fb645d3989d39acf4576d74615bbef38ebeee008b90
sha256sums = 33982486f7fafac35a33dfa37c85cfba8543aa78b5fe13c395d9cccf691ef4b3
diff --git a/PKGBUILD b/PKGBUILD
index 2c66aab5d2b2..1fc42ebd2974 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -23,7 +23,7 @@ source=('unreal-engine-4.sh'
'clang_path_fix.patch'
'ccache_executor.patch'
'unreal-engine-4-pacman-cache.hook')
-sha256sums=('c8771291d5ca38696686b06ad7affab496f5ab1b9c5570bd104c9542905a404e'
+sha256sums=('4180b39fe5ec3aa64a4b22171ddc677670190b011dc5a9457d0387959ec60e54'
'c04c03b2c5c933b7eb1af283d607934ad95fd57f44d62b83719061b555a85dca'
'960c5a100e0c3732f3c73fb645d3989d39acf4576d74615bbef38ebeee008b90'
'33982486f7fafac35a33dfa37c85cfba8543aa78b5fe13c395d9cccf691ef4b3'
diff --git a/unreal-engine-4.sh b/unreal-engine-4.sh
index 1fd3837a0158..9c69511f337d 100755
--- a/unreal-engine-4.sh
+++ b/unreal-engine-4.sh
@@ -29,8 +29,8 @@ fi
UE4desktopFileChecksum="$(sha256sum "${HOME}/local/share/applications/com.unrealengine.UE4Editor.desktop" | cut -f 1 -d ' ')"
if [ "${UE4desktopFileChecksum}" == "ChecksumPlaceholder" ]; then
- UE4editorLocation=$(find InstalledLocationPlaceholder -type f -iname 'UE4Editor')
- UE4editorPath=$(${UE4editorLocation} | sed 's/UE4Editor//')
+ UE4editorLocation="$(find InstalledLocationPlaceholder -type f -iname 'UE4Editor')"
+ UE4editorPath="$(echo ${UE4editorLocation/UE4Editor/})"
sed -i "7c\Exec=${UE4editorLocation} %F" "${HOME}/local/share/applications/com.unrealengine.UE4Editor.desktop"
sed -i "14c\Path=${UE4editorPath}" "${HOME}/local/share/applications/com.unrealengine.UE4Editor.desktop"