summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStanislav Seletskiy2015-06-22 10:44:45 +0600
committerStanislav Seletskiy2015-06-22 10:44:45 +0600
commitc4e4f7d09574cf1dc1baf9e2f6e9afa690aac36b (patch)
treec95e2bd3ae1b28796182a46068a74aa62bd86127
downloadaur-urxvt-fifo.tar.gz
initial commit
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD19
2 files changed, 31 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3a3938a12b1c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = urxvt-fifo
+ pkgdesc = Extension for sending keys to urxvt via fifo
+ pkgver = 3.9a75925
+ pkgrel = 1
+ url = https://github.com/kovetskiy/urxvt-fifo
+ arch = any
+ license = GPL
+ source = git+https://github.com/kovetskiy/urxvt-fifo
+ md5sums = SKIP
+
+pkgname = urxvt-fifo
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..106c41c2807e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+pkgname="urxvt-fifo"
+pkgver=3.9a75925
+pkgrel=1
+pkgdesc="Extension for sending keys to urxvt via fifo"
+url="https://github.com/kovetskiy/urxvt-fifo"
+arch=('any')
+license=('GPL')
+makedepends=()
+source=(git+https://github.com/kovetskiy/urxvt-fifo)
+md5sums=(SKIP)
+
+pkgver() {
+ cd "${pkgname}"
+ echo $(git rev-list --count master).$(git rev-parse --short master)
+}
+
+package() {
+ install -Dm644 $srcdir/$pkgname/fifo "$pkgdir"/usr/lib/urxvt/perl/fifo
+}