summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Hebb2021-01-17 23:49:59 -0800
committerThomas Hebb2021-01-18 00:05:07 -0800
commit599c495106826daf9a3ad8a18d973637b8d17afe (patch)
tree4a4efd6e057d9c8946551625cbac588d2355005d
parentf5378179662cdeb8e0adc2320e6181988218c0cf (diff)
downloadaur-599c495106826daf9a3ad8a18d973637b8d17afe.tar.gz
Fix a number of new build issues in the latest Git
-rw-r--r--PKGBUILD5
-rw-r--r--fix-linux-build.patch40
2 files changed, 44 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bfb8bde20027..cdbe2046c5a3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -15,9 +15,11 @@ install="usbdm.install"
source=("git+https://github.com/podonoghue/usbdm-eclipse-makefiles-build.git"
"undebian.patch"
+ "fix-linux-build.patch"
"60-usbdm.rules")
sha256sums=('SKIP'
'69407963c3aa12cdee47e100c64a3de76e2c182b7e33a3e486448a2581710457'
+ '4388b5ace7f37c8b036892aecde8d881c559b315e7e1b3adaec74eddea1fef0a'
'88eaab73a1020ac84d4979a4f70f122214b0042d167942a95bddd0560f0e3aa8')
pkgver() {
@@ -28,12 +30,13 @@ pkgver() {
prepare() {
cd "${srcdir}/usbdm-eclipse-makefiles-build"
patch -p1 -i "${srcdir}/undebian.patch"
+ patch -p1 -i "${srcdir}/fix-linux-build.patch"
sed -i -e 's/xercesc_3_1/xercesc/g' 'MergeXML/src/xmlParser.h'
}
build() {
cd "${srcdir}/usbdm-eclipse-makefiles-build"
- make -f Makefile-x64.mk
+ make -f Makefile-x64.mk all
}
package() {
diff --git a/fix-linux-build.patch b/fix-linux-build.patch
new file mode 100644
index 000000000000..238f2f0d5823
--- /dev/null
+++ b/fix-linux-build.patch
@@ -0,0 +1,40 @@
+diff --git a/Common.mk b/Common.mk
+index f16d4bdb..bbf648ac 100644
+--- a/Common.mk
++++ b/Common.mk
+@@ -11,10 +11,6 @@ PKG_NAME = usbdm
+ # Used as prefix with the above when in build directory $(DUMMY_CHILD)/$(SHARED_SRC) = PackageFiles/src
+ DUMMY_CHILD := PackageFiles
+
+-ifeq ('$(OS)','')
+- OS=Windows_NT
+-endif
+-
+ #BITNESS ?= 64
+
+ ifeq ($(OS),Windows_NT)
+@@ -270,7 +266,7 @@ ifeq ($(UNAME_S),Windows)
+ USBDM_DSC_LIBS := -lusbdm-dsc$(VSUFFIX)
+ endif
+ else
+- LIB_USB = -l$(_LIB_USB_SHARED)
++ LIB_USB = $(LIB_USB_SHARED)
+ ifdef DEBUG
+ USBDM_LIBS := -lusbdm-debug
+ USBDM_DSC_LIBS := -lusbdm-dsc-debug
+diff --git a/UsbdmJni_DLL/Target.mk b/UsbdmJni_DLL/Target.mk
+index 3fd428a3..0826ed8e 100644
+--- a/UsbdmJni_DLL/Target.mk
++++ b/UsbdmJni_DLL/Target.mk
+@@ -32,9 +32,9 @@ CC = $(GPP)
+ CFLAGS += -fno-exceptions
+
+ LDFLAGS += $(LFLAGS)
+-LDFLAGS += -Wl,--kill-at -shared
++LDFLAGS += -shared
+ ifeq ($(UNAME_S),Windows)
+-LDFLAGS +=
++LDFLAGS += -Wl,--kill-at
+ else
+ LDFLAGS += -Wl,-soname,$(basename $(notdir $@))
+ endif