summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Hebb2022-05-08 13:49:30 -0700
committerThomas Hebb2022-05-08 13:50:04 -0700
commitc8a5ba4db75a94fde3d5c7029aa04e946bc4158b (patch)
treecfb883156145dc08959005fb079ee92e6ac5c80b
parente9509a96035774dfe923b3630e6d231b31c1c60c (diff)
downloadaur-c8a5ba4db75a94fde3d5c7029aa04e946bc4158b.tar.gz
Remove some more unwanted multilib code in undebian.patch
This gets rid of some "uninstalled dependency" errors in namcap that resulted from an extra (harmless) slash in RPATH.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD2
-rw-r--r--undebian.patch86
3 files changed, 77 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7296664a5eeb..9fdc20f9bcea 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -18,7 +18,7 @@ pkgbase = usbdm-git
source = undebian.patch
source = 60-usbdm.rules
sha256sums = SKIP
- sha256sums = c12b63567e9623b1587aac6140b20976b29ac063d7c21c7221b295be64cd5dec
+ sha256sums = 1df36643f505b6869e3135f43ff1e738b25b19be58a3742978158873898f6e13
sha256sums = 88eaab73a1020ac84d4979a4f70f122214b0042d167942a95bddd0560f0e3aa8
pkgname = usbdm-git
diff --git a/PKGBUILD b/PKGBUILD
index 33a167b66e0f..5afa1e9d5928 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -17,7 +17,7 @@ source=("git+https://github.com/podonoghue/usbdm-eclipse-makefiles-build.git"
"undebian.patch"
"60-usbdm.rules")
sha256sums=('SKIP'
- 'c12b63567e9623b1587aac6140b20976b29ac063d7c21c7221b295be64cd5dec'
+ '1df36643f505b6869e3135f43ff1e738b25b19be58a3742978158873898f6e13'
'88eaab73a1020ac84d4979a4f70f122214b0042d167942a95bddd0560f0e3aa8')
pkgver() {
diff --git a/undebian.patch b/undebian.patch
index d240e3b03c19..9d80f5fb5ffb 100644
--- a/undebian.patch
+++ b/undebian.patch
@@ -1,13 +1,31 @@
-commit cc1b5ead1bb6f553c8952271267c6dfcb242c065
-Author: Thomas Hebb <tommyhebb@gmail.com>
-Date: Sun May 8 11:46:08 2022 -0700
+From 11c8680c8d0ec0e9c834f57efdfd3827453f4c6a Mon Sep 17 00:00:00 2001
+Message-Id: <11c8680c8d0ec0e9c834f57efdfd3827453f4c6a.1652042168.git.tommyhebb@gmail.com>
+From: Thomas Hebb <tommyhebb@gmail.com>
+Date: Sun, 8 May 2022 11:46:08 -0700
+Subject: [PATCH 1/2] Remove Debian-specific bits from Makefiles
- Remove Debian-specific bits from Makefiles
+The main change here is to get rid of architecture-specific library
+directories.
+---
+ Common.mk | 4 ++--
+ Library.mk | 22 +++++++---------------
+ USBDM_API_Example/Common.mk | 4 ++--
+ USBDM_Programmer_API_Example/Common.mk | 4 ++--
+ 4 files changed, 13 insertions(+), 21 deletions(-)
diff --git a/Common.mk b/Common.mk
-index c941f787..9674bc66 100755
+index c941f787..aa94a528 100755
--- a/Common.mk
+++ b/Common.mk
+@@ -53,7 +53,7 @@ SHARED_LIBDIR := ../Shared/$(MULTIARCH)
+
+ #===========================================================
+ # Where to find private libraries on linux
+-PKG_LIBDIR="/usr/lib/$(MULTIARCH)/${PKG_NAME}"
++PKG_LIBDIR="/usr/lib/${PKG_NAME}"
+
+ #===========================================================
+ # Where to build
@@ -257,7 +257,7 @@ ifeq ($(UNAME_S),Windows)
JAVA_INC := -I$(JAVA_DIR)/include
JAVA_INC += -I$(JAVA_DIR)/include/win32
@@ -18,14 +36,23 @@ index c941f787..9674bc66 100755
#=============================================================
diff --git a/Library.mk b/Library.mk
-index 00e780a3..e4eec7bd 100644
+index 00e780a3..76b8047d 100644
--- a/Library.mk
+++ b/Library.mk
-@@ -39,17 +39,8 @@ ifeq ($(UNAME_S),Windows)
- else
+@@ -10,8 +10,7 @@ USBDM_VERSION := $(MAJOR_VERSION).$(MINOR_VERSION)
+
+ #===========================================================
+ # Where to find private libraries on linux
+-USBDM_LIBDIR32="/usr/lib/i386-linux-gnu/usbdm"
+-USBDM_LIBDIR64="/usr/lib/x86_64-linux-gnu/usbdm"
++USBDM_LIBDIR="/usr/lib/usbdm"
+
+ #===========================================================
+ # Shared directories - Relative to child directory
+@@ -40,16 +39,8 @@ else
# Assume Linux
DIRS = $(COMMON_DIRS)
-- BITNESS ?= $(shell getconf LONG_BIT)
+ BITNESS ?= $(shell getconf LONG_BIT)
- ifeq ($(BITNESS),32)
- TARGET_BINDIR ?= ../PackageFiles/bin/i386-linux-gnu
- TARGET_LIBDIR ?= ../PackageFiles/lib/i386-linux-gnu
@@ -50,10 +77,35 @@ index 00e780a3..e4eec7bd 100644
endif
#=============================================================
+@@ -315,12 +306,13 @@ endif
+ ifneq ($(OS),Windows_NT)
+ ifeq ($(BITNESS),32)
+ CFLAGS += -m32
+- LDFLAGS += -m32 -Wl,-rpath,${USBDM_LIBDIR32}
++ LDFLAGS += -m32
+ endif
+ ifeq ($(BITNESS),64)
+ CFLAGS += -m64
+- LDFLAGS += -m64 -Wl,-rpath,${USBDM_LIBDIR64}
++ LDFLAGS += -m64
+ endif
++ LDFLAGS += -Wl,-rpath,${USBDM_LIBDIR}
+ endif
+
+ CFLAGS += ${THREADS} -Wall -shared ${GCC_VISIBILITY_DEFS}
diff --git a/USBDM_API_Example/Common.mk b/USBDM_API_Example/Common.mk
-index 5f79c882..e27e4090 100755
+index 5f79c882..bc877eab 100755
--- a/USBDM_API_Example/Common.mk
+++ b/USBDM_API_Example/Common.mk
+@@ -49,7 +49,7 @@ SHARED_LIBDIR := ../Shared/$(MULTIARCH)
+
+ #===========================================================
+ # Where to find private libraries on linux
+-PKG_LIBDIR="/usr/lib/$(MULTIARCH)/${PKG_NAME}"
++PKG_LIBDIR="/usr/lib/${PKG_NAME}"
+
+ #===========================================================
+ # Where to build
@@ -258,7 +258,7 @@ ifeq ($(UNAME_S),Windows)
JAVA_INC := -I$(JAVA_DIR)/include
JAVA_INC += -I$(JAVA_DIR)/include/win32
@@ -64,9 +116,18 @@ index 5f79c882..e27e4090 100755
#=============================================================
diff --git a/USBDM_Programmer_API_Example/Common.mk b/USBDM_Programmer_API_Example/Common.mk
-index 5f79c882..e27e4090 100755
+index 5f79c882..bc877eab 100755
--- a/USBDM_Programmer_API_Example/Common.mk
+++ b/USBDM_Programmer_API_Example/Common.mk
+@@ -49,7 +49,7 @@ SHARED_LIBDIR := ../Shared/$(MULTIARCH)
+
+ #===========================================================
+ # Where to find private libraries on linux
+-PKG_LIBDIR="/usr/lib/$(MULTIARCH)/${PKG_NAME}"
++PKG_LIBDIR="/usr/lib/${PKG_NAME}"
+
+ #===========================================================
+ # Where to build
@@ -258,7 +258,7 @@ ifeq ($(UNAME_S),Windows)
JAVA_INC := -I$(JAVA_DIR)/include
JAVA_INC += -I$(JAVA_DIR)/include/win32
@@ -76,3 +137,6 @@ index 5f79c882..e27e4090 100755
endif
#=============================================================
+--
+2.36.0
+