summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrià Cabello2023-05-27 19:06:59 +0200
committerAdrià Cabello2023-05-27 19:06:59 +0200
commit83e44b7410288242692b6218f3a8b62a665f2b04 (patch)
tree68b000320efa966a6f410994e5aac300f9295fe1
parent1ed0e049ef2ee732d5cb488edfe4f7fbdca0e109 (diff)
downloadaur-83e44b7410288242692b6218f3a8b62a665f2b04.tar.gz
fixed memset warning
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD9
-rw-r--r--memset.patch13
3 files changed, 22 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 031d9fcad1d5..c20344664d5c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = usd
pkgdesc = 3D VFX pipeline interchange file format
pkgver = 23.05
- pkgrel = 4
+ pkgrel = 5
url = https://openusd.org
arch = x86_64
license = Apache
@@ -35,11 +35,13 @@ pkgbase = usd
source = tbbgcc13.patch
source = pyside6.patch
source = materialx.patch
+ source = memset.patch
sha512sums = SKIP
sha512sums = 6bcc014ec90cd62293811ac436eab03c7f7c7e3e03109efcab1c42cfed48d8bf83073d03ab381e5e63ee8c905f1792a7fdab272ec7e585df14102bad714ffc15
sha512sums = 6ab652c77dddc5a69cfc3f09974ba66f1413d699e49734c7ed31c629f5368230e0adaf95f599eafbf9316660d67b0b011b52ac1552d814564cbb2967bd927fdd
sha512sums = e9d4d37b6243b32dc4dbf1ab8b5b1c6a2ceb87a81b7ac711afd95244131ac5305e2369b93581c4670ca15f8cdc42482a8cd373e22779322d52e66e2a5ecdf08b
sha512sums = ba35f847b023139dcc3b38ec9308d52c7358967f22c38d481a0a9d9fee1ced674b56850bc9f7e07c350a144c1e575ec1f77a1a0b970dc4ceddcae904d6bc403f
sha512sums = 167e9bb2bced935cd9513b4ecd40c9e73ada0c794f1e5f11dc3e2844bedc07ac082aa8fb88e50c86dc2c80854ed95ddc22472f6fdc978765398079164d1c15c5
+ sha512sums = SKIP
pkgname = usd
diff --git a/PKGBUILD b/PKGBUILD
index d5932ab92631..d49216223eab 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
# Maintainer: Adrià Cabello <adro.cc79 at protonmail dot com>
-# Maintainer: Caleb Maclennan <caleb@alerque.com>
+# Co-Maintainer: Caleb Maclennan <caleb@alerque.com>
# Contributor: Started by https://github.com/qumaciel at https://github.com/PixarAnimationStudios/USD/issues/2000
# WARNING This USD build is not intended for building Blender.
@@ -9,7 +9,7 @@ _tbbpkgminorver=6
pkgname=usd
pkgver=23.05
-pkgrel=4
+pkgrel=5
pkgdesc='3D VFX pipeline interchange file format'
arch=(x86_64)
url='https://openusd.org'
@@ -47,16 +47,19 @@ source=("git+$_url.git#tag=v$pkgver"
"tbbgcc13.patch"
"pyside6.patch"
"materialx.patch"
+ "memset.patch"
)
sha512sums=('SKIP'
'6bcc014ec90cd62293811ac436eab03c7f7c7e3e03109efcab1c42cfed48d8bf83073d03ab381e5e63ee8c905f1792a7fdab272ec7e585df14102bad714ffc15'
'6ab652c77dddc5a69cfc3f09974ba66f1413d699e49734c7ed31c629f5368230e0adaf95f599eafbf9316660d67b0b011b52ac1552d814564cbb2967bd927fdd'
'e9d4d37b6243b32dc4dbf1ab8b5b1c6a2ceb87a81b7ac711afd95244131ac5305e2369b93581c4670ca15f8cdc42482a8cd373e22779322d52e66e2a5ecdf08b'
'ba35f847b023139dcc3b38ec9308d52c7358967f22c38d481a0a9d9fee1ced674b56850bc9f7e07c350a144c1e575ec1f77a1a0b970dc4ceddcae904d6bc403f'
- '167e9bb2bced935cd9513b4ecd40c9e73ada0c794f1e5f11dc3e2844bedc07ac082aa8fb88e50c86dc2c80854ed95ddc22472f6fdc978765398079164d1c15c5')
+ '167e9bb2bced935cd9513b4ecd40c9e73ada0c794f1e5f11dc3e2844bedc07ac082aa8fb88e50c86dc2c80854ed95ddc22472f6fdc978765398079164d1c15c5'
+ 'SKIP')
prepare() {
patch --directory=USD --forward --strip=1 --input="${srcdir}/pyside6.patch"
+ patch --directory=USD --forward --strip=1 --input="${srcdir}/memset.patch"
patch --directory=USD --forward --strip=1 --input="${srcdir}/materialx.patch"
#TBB
mkdir -p "${srcdir}"/tbb2019
diff --git a/memset.patch b/memset.patch
new file mode 100644
index 000000000000..3b02977e2856
--- /dev/null
+++ b/memset.patch
@@ -0,0 +1,13 @@
+diff --git a/pxr/usd/sdf/path.h b/pxr/usd/sdf/path.h
+index a0986d26d..3fafa5ae3 100644
+--- a/pxr/usd/sdf/path.h
++++ b/pxr/usd/sdf/path.h
+@@ -308,7 +308,7 @@ public:
+ SdfPath() noexcept {
+ // This generates a single instruction instead of 2 on gcc 6.3. Seems
+ // to be fixed on gcc 7+ and newer clangs. Remove when we're there!
+- memset(this, 0, sizeof(*this));
++ *this = SdfPath();
+ }
+
+ /// Creates a path from the given string.