summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicolas Iooss2014-08-14 16:06:33 +0200
committerNicolas Iooss2015-06-27 12:16:31 +0800
commitcb21f82a196139a1a5d0a0714896ab887a0360cb (patch)
tree8f068e7bcecf89e8c26c3f5264a9114f33dc909e
parent27fea911741a0240056b866c57aa287844b6284a (diff)
downloadaur-cb21f82a196139a1a5d0a0714896ab887a0360cb.tar.gz
util-linux-selinux 2.25-1 update
-rw-r--r--.SRCINFO17
-rw-r--r--0001-fdisk-fix-l-device.patch61
-rw-r--r--PKGBUILD30
3 files changed, 85 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 89d8f897ed0d..2d0d9bfd062f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = util-linux-selinux
pkgdesc = SELinux aware miscellaneous system utilities for Linux
- pkgver = 2.24.2
+ pkgver = 2.25
pkgrel = 1
url = http://www.kernel.org/pub/linux/utils/util-linux/
arch = i686
@@ -11,16 +11,18 @@ pkgbase = util-linux-selinux
makedepends = python
options = strip
options = debug
- source = ftp://ftp.kernel.org/pub/linux/utils/util-linux/v2.24/util-linux-2.24.2.tar.xz
+ source = ftp://ftp.kernel.org/pub/linux/utils/util-linux/v2.25/util-linux-2.25.tar.xz
source = uuidd.tmpfiles
source = pam-login
source = pam-common
source = pam-su
- md5sums = 3f191727a0d28f7204b755cf1b6ea0aa
+ source = 0001-fdisk-fix-l-device.patch
+ md5sums = 4c78fdef4cb882caafad61e33cafbc14
md5sums = a39554bfd65cccfd8254bb46922f4a67
md5sums = 4368b3f98abd8a32662e094c54e7f9b1
md5sums = a31374fef2cba0ca34dfc7078e2969e4
md5sums = fa85e5cce5d723275b14365ba71a8aad
+ md5sums = 93cf977a7abc6f30152295e2aef453fa
pkgname = util-linux-selinux
install = util-linux.install
@@ -30,10 +32,10 @@ pkgname = util-linux-selinux
depends = libsystemd-selinux
depends = libutil-linux-selinux
optdepends = python: python bindings to libmount
- provides = util-linux-ng=2.24.2
+ provides = util-linux-ng=2.25
provides = eject
- provides = util-linux=2.24.2-
- provides = selinux-util-linux=2.24.2-
+ provides = util-linux=2.25-
+ provides = selinux-util-linux=2.25-
conflicts = util-linux-ng
conflicts = eject
conflicts = util-linux
@@ -48,7 +50,8 @@ pkgname = libutil-linux-selinux
pkgdesc = util-linux-selinux runtime libraries
provides = libblkid.so
provides = libmount.so
+ provides = libsmartcols.so
provides = libuuid.so
- provides = libutil-linux=2.24.2-
+ provides = libutil-linux=2.25-
conflicts = libutil-linux
diff --git a/0001-fdisk-fix-l-device.patch b/0001-fdisk-fix-l-device.patch
new file mode 100644
index 000000000000..ed0e748e3dd6
--- /dev/null
+++ b/0001-fdisk-fix-l-device.patch
@@ -0,0 +1,61 @@
+From 52d92543ffb8efb56036f316a1072d8fbba62c38 Mon Sep 17 00:00:00 2001
+From: Karel Zak <kzak@redhat.com>
+Date: Mon, 28 Jul 2014 11:57:10 +0200
+Subject: [PATCH] fdisk: fix -l [<device>]
+
+ * don't use err(), but warn(), so don't stop after the first error
+
+ * display all errors when "-l <device> ..." specified
+
+ * display only EACCES errors when list whole disks from
+ /proc/partitions ("fdisk -l" )
+
+Reported-by: Boian Bonev <bbonev@ipacct.com>
+Addresses: https://github.com/karelzak/util-linux/pull/106
+Signed-off-by: Karel Zak <kzak@redhat.com>
+---
+ disk-utils/fdisk.c | 13 ++++++++-----
+ 1 file changed, 8 insertions(+), 5 deletions(-)
+
+diff --git a/disk-utils/fdisk.c b/disk-utils/fdisk.c
+index 8d57dbb..46e632a 100644
+--- a/disk-utils/fdisk.c
++++ b/disk-utils/fdisk.c
+@@ -670,10 +670,13 @@ static int is_ide_cdrom_or_tape(char *device)
+ return ret;
+ }
+
+-static void print_device_pt(struct fdisk_context *cxt, char *device)
++static void print_device_pt(struct fdisk_context *cxt, char *device, int warnme)
+ {
+- if (fdisk_context_assign_device(cxt, device, 1) != 0) /* read-only */
+- err(EXIT_FAILURE, _("cannot open %s"), device);
++ if (fdisk_context_assign_device(cxt, device, 1) != 0) { /* read-only */
++ if (warnme || errno == EACCES)
++ warn(_("cannot open %s"), device);
++ return;
++ }
+
+ list_disk_geometry(cxt);
+
+@@ -717,7 +720,7 @@ static void print_all_devices_pt(struct fdisk_context *cxt)
+ if (!cn)
+ continue;
+ if (!is_ide_cdrom_or_tape(cn))
+- print_device_pt(cxt, cn);
++ print_device_pt(cxt, cn, 0);
+ free(cn);
+ }
+ fclose(f);
+@@ -912,7 +915,7 @@ int main(int argc, char **argv)
+ if (argc > optind) {
+ int k;
+ for (k = optind; k < argc; k++)
+- print_device_pt(cxt, argv[k]);
++ print_device_pt(cxt, argv[k], 1);
+ } else
+ print_all_devices_pt(cxt);
+ break;
+--
+2.0.3
+
diff --git a/PKGBUILD b/PKGBUILD
index ebb05100c858..1b546898d39b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@
pkgbase=util-linux-selinux
pkgname=(util-linux-selinux libutil-linux-selinux)
-pkgver=2.24.2
+pkgver=2.25
pkgrel=1
pkgdesc="SELinux aware miscellaneous system utilities for Linux"
url="http://www.kernel.org/pub/linux/utils/util-linux/"
@@ -20,19 +20,26 @@ groups=('selinux')
# provided by libsystemd (FS#39767). To break this cycle, make
# util-linux-selinux depend on systemd at build time.
makedepends=('systemd' 'python')
-# checkdepends=('bc')
license=('GPL2')
options=('strip' 'debug')
-source=("ftp://ftp.kernel.org/pub/linux/utils/${pkgname/-selinux}/v2.24/${pkgname/-selinux}-$pkgver.tar.xz"
+source=("ftp://ftp.kernel.org/pub/linux/utils/${pkgname/-selinux}/v2.25/${pkgname/-selinux}-$pkgver.tar.xz"
uuidd.tmpfiles
pam-login
pam-common
- pam-su)
-md5sums=('3f191727a0d28f7204b755cf1b6ea0aa'
+ pam-su
+ 0001-fdisk-fix-l-device.patch)
+md5sums=('4c78fdef4cb882caafad61e33cafbc14'
'a39554bfd65cccfd8254bb46922f4a67'
'4368b3f98abd8a32662e094c54e7f9b1'
'a31374fef2cba0ca34dfc7078e2969e4'
- 'fa85e5cce5d723275b14365ba71a8aad')
+ 'fa85e5cce5d723275b14365ba71a8aad'
+ '93cf977a7abc6f30152295e2aef453fa')
+
+prepare() {
+ cd "${pkgname/-selinux}-$pkgver"
+
+ patch -Np1 <"$srcdir"/0001-fdisk-fix-l-device.patch
+}
build() {
cd "${pkgname/-selinux}-$pkgver"
@@ -52,18 +59,9 @@ build() {
--with-selinux \
--with-python=3
-# --enable-reset \ # part of ncurses
-# --enable-last \ # not compat
-
make
}
-#check() {
-# fails for some reason in chroot, works outside
-# make -C "${pkgname/-selinux}-$pkgver" check
-#}
-
-
package_util-linux-selinux() {
conflicts=('util-linux-ng' 'eject'
"${pkgname/-selinux}" "selinux-${pkgname/-selinux}")
@@ -112,7 +110,7 @@ package_util-linux-selinux() {
package_libutil-linux-selinux() {
pkgdesc="util-linux-selinux runtime libraries"
- provides=('libblkid.so' 'libmount.so' 'libuuid.so'
+ provides=('libblkid.so' 'libmount.so' 'libsmartcols.so' 'libuuid.so'
"${pkgname/-selinux}=${pkgver}-${pkrel}")
conflicts=("${pkgname/-selinux}")