summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSam2021-09-13 16:42:49 -0700
committerSam2021-09-13 16:42:49 -0700
commit16c0c6e8dd19249dde50ecbe9e7acff0a2e1e4d4 (patch)
treedeaca560ee51bf6f87c468b056af3502cf5cd070
parente3b280e017428ff638dee103cbc8f4cde554e308 (diff)
downloadaur-uutils-coreutils-git.tar.gz
build: updated to match community build, skipped tests are different
-rw-r--r--.SRCINFO9
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD42
3 files changed, 37 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 86ad79aa7db4..ebe345967ea7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,19 @@
pkgbase = uutils-coreutils-git
pkgdesc = GNU Coreutils rewritten in Rust
- pkgver = r2675.1dc7d8cb
+ pkgver = r5937.e9d63519d
pkgrel = 1
url = https://github.com/uutils/coreutils
arch = x86_64
license = MIT
+ makedepends = git
makedepends = rust
makedepends = cargo
- makedepends = python-sphinx
makedepends = cmake
+ makedepends = python-sphinx
+ depends = glibc
+ depends = gcc-libs
+ conflicts = uutils-coreutils
source = git+https://github.com/uutils/coreutils.git
sha512sums = SKIP
pkgname = uutils-coreutils-git
-
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..209eaaefe67f
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/*
+!PKGBUILD
+!.SRCINFO
+!.gitignore
diff --git a/PKGBUILD b/PKGBUILD
index a3352ae7085d..be04d7410bd7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,34 +1,46 @@
-# Maintainer: Árni Dagur <arnidg@protonmail.ch>
+# Maintainer: Sam <dev at samarthj dot com>
+# Contributor: Árni Dagur <arnidg@protonmail.ch>
-_shortname='uutils-coreutils'
-pkgname="${_shortname}-git"
-pkgver=r2675.1dc7d8cb
+# shellcheck disable=2034,2148,2154
+
+_pkgname='uutils-coreutils'
+pkgname="${_pkgname}-git"
+pkgver=r5937.e9d63519d
pkgrel=1
pkgdesc="GNU Coreutils rewritten in Rust"
arch=('x86_64')
url='https://github.com/uutils/coreutils'
license=('MIT')
-makedepends=('git' 'rust' 'cargo' 'python-sphinx' 'cmake')
+depends=('glibc' 'gcc-libs')
+makedepends=('git' 'rust' 'cargo' 'cmake' 'python-sphinx')
conflicts=('uutils-coreutils')
source=("git+https://github.com/uutils/coreutils.git")
sha512sums=('SKIP')
pkgver() {
- cd coreutils
+ cd coreutils || exit 1
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
-check() {
- cd coreutils
+build() {
+ cd coreutils || exit 1
+ make PROFILE=release
+}
- # Run Cargo tests
- make -j1 test
- # Run BusyBox test suite
- # make -j1 busytest
+check() {
+ cd coreutils || exit 1
+ # TODO: Fix the failing tests. These 4 seem to fail for a few benign reasons.
+ make test \
+ TEST_NO_FAIL_FAST="--no-fail-fast -- --skip test_chown::test_chown_only_group --skip test_chown::test_chown_only_group_id --skip test_pinky::test_no_flag --skip test_who::test_lookup"
}
package() {
- cd coreutils
- make -j1 PREFIX=/opt/${_shortname}/ DESTDIR="$pkgdir" install
- install -Dm644 LICENSE "$pkgdir/usr/share/licenses/${_shortname}/LICENSE"
+ cd coreutils || exit 1
+ make install \
+ DESTDIR="$pkgdir" \
+ PREFIX=/usr \
+ MANDIR=/share/man/man1 \
+ PROG_PREFIX=uu- \
+ PROFILE=release
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/${pkgname}/LICENSE"
}