summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorD3SOX2021-09-29 20:41:57 +0200
committerD3SOX2021-09-29 20:41:57 +0200
commit5d40139e46daeb582c4236527dbb533d9293df97 (patch)
tree711fe22542c3ba574dfa733b0dd5600a25aa8591
downloadaur-5d40139e46daeb582c4236527dbb533d9293df97.tar.gz
initial import
-rw-r--r--.SRCINFO23
-rwxr-xr-xPKGBUILD32
-rwxr-xr-xuxplay.desktop10
3 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a1b5d8fab202
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = uxplay
+ pkgdesc = AirPlay Unix mirroring server
+ pkgver = 1.35.1
+ pkgrel = 1
+ url = https://github.com/FDH2/UxPlay
+ arch = any
+ license = GPL3
+ makedepends = cmake
+ depends = gstreamer
+ depends = gst-plugins-base
+ depends = gst-plugins-base-libs
+ depends = gst-libav
+ depends = gstreamer-vaapi
+ depends = avahi
+ depends = libplist
+ provides = uxplay
+ conflicts = uxplay
+ source = UxPlay-1.35.1.tar.gz::https://github.com/FDH2/UxPlay/archive/refs/tags/v1.35.1.tar.gz
+ source = uxplay.desktop
+ sha256sums = d29ed97849600e8a91e7bd2a4d2fbb02311eddcd4d443612cf804687200fd530
+ sha256sums = 6b43385942508d8c360e8360be52719cbf3899868f3560b245731d866fb245a3
+
+pkgname = uxplay
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..0abac808530d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Nico <d3sox at protonmail dot com>
+pkgname=uxplay
+_gitname=UxPlay
+pkgver=1.35.1
+pkgrel=1
+pkgdesc="AirPlay Unix mirroring server"
+arch=('any')
+url="https://github.com/FDH2/$_gitname"
+license=('GPL3')
+depends=('gstreamer' 'gst-plugins-base' 'gst-plugins-base-libs' 'gst-libav' 'gstreamer-vaapi' 'avahi' 'libplist')
+makedepends=('cmake')
+conflicts=('uxplay')
+provides=('uxplay')
+source=("$_gitname-$pkgver.tar.gz::$url/archive/refs/tags/v$pkgver.tar.gz" "uxplay.desktop")
+sha256sums=('d29ed97849600e8a91e7bd2a4d2fbb02311eddcd4d443612cf804687200fd530' '6b43385942508d8c360e8360be52719cbf3899868f3560b245731d866fb245a3')
+
+build() {
+ cd "$srcdir/$_gitname-$pkgver"
+ mkdir -p build
+ cd build
+ cmake .. -DZOOMFIX=1
+ cmake --build . --config Release
+}
+
+package() {
+ # install binary
+ install -Dm 755 "$srcdir/$_gitname-$pkgver/build/uxplay" "$pkgdir/usr/bin/uxplay"
+ # install desktop file
+ install -Dm 644 "$srcdir/uxplay.desktop" "$pkgdir/usr/share/applications/uxplay.desktop"
+
+ printf "%b" "\e[1;33m==> WARNING: \e[0mIn order for UxPlay to work, the avahi systemd service has to be running. Enable it with: systemctl enable --now avahi-daemon\n"
+}
diff --git a/uxplay.desktop b/uxplay.desktop
new file mode 100755
index 000000000000..733ecd603e57
--- /dev/null
+++ b/uxplay.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Type=Application
+Version=1.0
+Name=UxPlay
+GenericName=AirPlay server
+Exec=/usr/bin/uxplay
+Icon=computer-apple-ipad-symbolic
+Terminal=true
+Categories=AudioVideo;
+Comment=AirPlay Unix mirroring server