summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoroli2015-06-12 22:02:42 +0200
committeroli2015-06-12 22:02:42 +0200
commit7d0f99137e5063fc08f4228ac930e9793b122f7c (patch)
treeb1cd721627c297835ee944c45795f9f0041b9e08
downloadaur-uxtank.tar.gz
Initial import
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD25
-rw-r--r--uxtank.desktop7
3 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c37e8cc08666
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = uxtank
+ pkgdesc = tank game for Linux
+ pkgver = 2.3
+ pkgrel = 3
+ url = https://sites.google.com/site/uxtank/home
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = sdl_mixer
+ depends = gcc-libs
+ depends = libxpm
+ source = http://sites.google.com/site/uxtank/uxtank2.3.tgz
+ source = uxtank.desktop
+ md5sums = eadecd55b58ffb66db6543f282ecdb68
+ md5sums = 313c689409fcd2f1093e5336f98c6960
+
+pkgname = uxtank
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5bf0b9d6ca2f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Jozef Riha <jose1711 at gmail dot com>
+
+pkgname=uxtank
+pkgver=2.3
+pkgrel=3
+pkgdesc="tank game for Linux"
+url="https://sites.google.com/site/uxtank/home"
+arch=('i686' 'x86_64')
+license=('GPL')
+source=("http://sites.google.com/site/${pkgname}/${pkgname}${pkgver}.tgz" "uxtank.desktop")
+depends=('sdl_mixer' 'gcc-libs' 'libxpm')
+md5sums=('eadecd55b58ffb66db6543f282ecdb68' '313c689409fcd2f1093e5336f98c6960')
+
+build() {
+cd $srcdir/${pkgname}${pkgver}
+sed -i '/^LIB=/s%.*%LIB=-L/usr/X11R6/lib -lXpm -lX11 -L/usr/lib -lSDL_mixer -lSDL%' Makefile
+make
+}
+
+package() {
+cd $srcdir/${pkgname}${pkgver}
+make DESTDIR=${pkgdir} install
+install -D -m644 $srcdir/${pkgname}${pkgver}/icons/uxtank.xpm $pkgdir/usr/share/pixmaps/uxtank.xpm
+install -D -m644 $srcdir/uxtank.desktop $pkgdir/usr/share/applications/uxtank.desktop
+}
diff --git a/uxtank.desktop b/uxtank.desktop
new file mode 100644
index 000000000000..361d36baf68f
--- /dev/null
+++ b/uxtank.desktop
@@ -0,0 +1,7 @@
+[Desktop Entry]
+Type=Application
+Name=uxTank
+Comment=Tank game for Linux
+Exec=/usr/games/uxtank
+Icon=uxtank
+Categories=Game;ActionGame;