summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIan Watt2020-01-22 08:36:48 -0500
committerIan Watt2020-01-22 08:36:48 -0500
commit206c1aba440c1095fb15c83d5d13c05418620422 (patch)
tree216e1829565c48adf4bc8b83d3469fa99c9ebc68
parent730109961f285e77a494dc980a35865c9597a78b (diff)
downloadaur-vagrant-git.tar.gz
version bump to 2.2.6.203
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD25
2 files changed, 17 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 76a4e0b839f0..ee399b047819 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,13 @@
-# Generated by mksrcinfo v8
-# Thu Nov 2 11:39:13 UTC 2017
pkgbase = vagrant-git
pkgdesc = Build and distribute virtualized development environments
- pkgver = 2.0.0.101.g52824f20b
+ pkgver = 2.2.6.203.ga1abc177b
pkgrel = 1
url = https://vagrantup.com
arch = i686
arch = x86_64
license = MIT
makedepends = git
- makedepends = go-pie
+ makedepends = go
depends = curl
depends = libarchive
depends = libssh2
@@ -25,8 +23,8 @@ pkgbase = vagrant-git
replaces = vagrant-substrate
replaces = vagrant-substrate-git
options = !emptydirs
- source = git://github.com/mitchellh/vagrant.git
- source = git://github.com/mitchellh/vagrant-installers.git
+ source = git://github.com/hashicorp/vagrant.git
+ source = git://github.com/hashicorp/vagrant-installers.git
md5sums = SKIP
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index f21ce396c60e..89c1beebb0c2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,9 @@
-# Maintainer: Jonathan Steel <jsteel at archlinux.org>
+# Maintainer: Ian Watt <ian at ewatt.ca>
+# Contributor: Jonathan Steel <jsteel at archlinux.org>
_pkgname=vagrant
pkgname=vagrant-git
-pkgver=2.0.0.101.g52824f20b
+pkgver=2.2.6.203.ga1abc177b
pkgrel=1
pkgdesc="Build and distribute virtualized development environments"
arch=('i686' 'x86_64')
@@ -11,12 +12,12 @@ license=('MIT')
options=('!emptydirs')
depends=('curl' 'libarchive' 'libssh2' 'libxml2' 'libxslt' 'rsync'
'ruby' 'xz')
-makedepends=('git' 'go-pie')
+makedepends=('git' 'go')
provides=('vagrant')
conflicts=('vagrant' 'vagrant-substrate' 'vagrant-substrate-git')
replaces=('vagrant-substrate' 'vagrant-substrate-git')
-source=(git://github.com/mitchellh/$_pkgname.git
- git://github.com/mitchellh/vagrant-installers.git)
+source=(git://github.com/hashicorp/$_pkgname.git
+ git://github.com/hashicorp/vagrant-installers.git)
md5sums=('SKIP'
'SKIP')
@@ -29,13 +30,13 @@ pkgver() {
build() {
cd $_pkgname
- INSTALLERS_DIR="$srcdir"/vagrant-installers/substrate/modules
+ INSTALLERS_DIR="$srcdir"/vagrant-installers/substrate
gem build $_pkgname.gemspec
cp vagrant-*.gem vagrant.gem
- cd "$INSTALLERS_DIR"/vagrant_substrate/files/launcher
+ cd "$INSTALLERS_DIR"/launcher
go get github.com/mitchellh/osext
go build -o vagrant
}
@@ -43,21 +44,21 @@ build() {
package() {
cd $_pkgname
- INSTALLERS_DIR="$srcdir"/vagrant-installers/substrate/modules
+ INSTALLERS_DIR="$srcdir"/vagrant-installers/substrate
EMBEDDED_DIR="$pkgdir"/opt/vagrant/embedded
install -d "$pkgdir"/usr/{bin,share/bash-completion/completions}
- install -Dm644 "$INSTALLERS_DIR"/vagrant_substrate/templates/gemrc.erb \
+ install -Dm644 "$INSTALLERS_DIR"/common/gemrc \
"$EMBEDDED_DIR"/etc/gemrc
- cp -r "$INSTALLERS_DIR"/rubyencoder/files/rgloader "$EMBEDDED_DIR"
+ cp -r "$INSTALLERS_DIR"/common/rgloader "$EMBEDDED_DIR"
GEM_PATH="$EMBEDDED_DIR"/gems GEM_HOME="$GEM_PATH" \
GEMRC="$EMBEDDED_DIR"/etc/gemrc \
- gem install $_pkgname.gem --no-ri --no-rdoc
+ gem install $_pkgname.gem --no-document
- install -Dm755 "$INSTALLERS_DIR"/vagrant_substrate/files/launcher/vagrant \
+ install -Dm755 "$INSTALLERS_DIR"/launcher/vagrant \
"$pkgdir"/opt/$_pkgname/bin/$_pkgname
ln -s /opt/$_pkgname/bin/$_pkgname "$pkgdir"/usr/bin/$_pkgname