summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072022-03-13 03:05:11 +0100
committersL1pKn072022-03-13 03:05:11 +0100
commit2213fba42c807c6751b2537b7727d46b3abda641 (patch)
tree03fc9359231f560124517f7d557a2d2f45e1e1ee
parent057c412e80d24350de8f0a9172cf5adae0178289 (diff)
downloadaur-vapoursynth-plugin-degrainmedian-git.tar.gz
bump
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD14
2 files changed, 10 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 669613f52d29..51f526599efc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by mksrcinfo v8
-# Sat Mar 2 19:53:52 UTC 2019
pkgbase = vapoursynth-plugin-degrainmedian-git
pkgdesc = Plugin for Vapoursynth: degrainmedian (GIT version)
- pkgver = v1.1.g0704888
+ pkgver = 1.1.g0704888
pkgrel = 1
url = https://forum.doom9.org/showthread.php?t=173758
arch = x86_64
@@ -11,8 +9,8 @@ pkgbase = vapoursynth-plugin-degrainmedian-git
depends = vapoursynth
provides = vapoursynth-plugin-degrainmedian
conflicts = vapoursynth-plugin-degrainmedian
+ options = debug
source = degrainmedian::git+https://github.com/dubhater/vapoursynth-degrainmedian.git
sha256sums = SKIP
pkgname = vapoursynth-plugin-degrainmedian-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 4b0d2253b733..7fda3f98720e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_plug=degrainmedian
pkgname=vapoursynth-plugin-${_plug}-git
-pkgver=v1.1.g0704888
+pkgver=1.1.g0704888
pkgrel=1
pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
arch=('x86_64')
@@ -14,22 +14,24 @@ provides=("vapoursynth-plugin-${_plug}")
conflicts=("vapoursynth-plugin-${_plug}")
source=("${_plug}::git+https://github.com/dubhater/vapoursynth-${_plug}.git")
sha256sums=('SKIP')
+options=('debug')
pkgver() {
cd "${_plug}"
- echo "$(git describe --long --tags | tr - .)"
+ echo "$(git describe --long --tags | tr - . | tr -d v)"
}
prepare() {
mkdir -p build
- cd "${_plug}"
- ./autogen.sh
}
build() {
- cd build
- ../"${_plug}"/configure \
+ cd "${_plug}"
+ ./autogen.sh
+
+ cd "${srcdir}/build"
+ "../${_plug}/configure" \
--prefix=/usr \
--libdir=/usr/lib/vapoursynth