summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072022-03-13 17:36:43 +0100
committersL1pKn072022-03-13 17:36:43 +0100
commit7cd4eeae4fa9e4b9ffb69a8c395fa78293038d6c (patch)
treea2ec558aef32fcd7e6a2d724a1b0aa767f8b6f79
parent23fa17b7aeece7ffaa765f944191cbd066b69d5d (diff)
downloadaur-vapoursynth-plugin-nnedi3-git.tar.gz
bump
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD17
2 files changed, 10 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a7b2943caa8f..032627a9d5ee 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by mksrcinfo v8
-# Sat Mar 2 19:57:37 UTC 2019
pkgbase = vapoursynth-plugin-nnedi3-git
pkgdesc = Plugin for Vapoursynth: nnedi3 (GIT version)
- pkgver = v12.0.g8c35822
+ pkgver = 12.0.g8c35822
pkgrel = 1
url = http://forum.doom9.org/showthread.php?t=166434
arch = x86_64
@@ -13,8 +11,8 @@ pkgbase = vapoursynth-plugin-nnedi3-git
depends = vapoursynth-plugin-nnedi3_weights_bin
provides = vapoursynth-plugin-nnedi3
conflicts = vapoursynth-plugin-nnedi3
+ options = debug
source = nnedi3::git+https://github.com/dubhater/vapoursynth-nnedi3.git
sha256sums = SKIP
pkgname = vapoursynth-plugin-nnedi3-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 30396dbf5331..0d17ef84b001 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
-# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
_plug=nnedi3
pkgname=vapoursynth-plugin-${_plug}-git
-pkgver=v12.0.g8c35822
+pkgver=12.0.g8c35822
pkgrel=1
pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
arch=('x86_64')
@@ -18,25 +18,24 @@ provides=("vapoursynth-plugin-${_plug}")
conflicts=("vapoursynth-plugin-${_plug}")
source=("${_plug}::git+https://github.com/dubhater/vapoursynth-${_plug}.git")
sha256sums=('SKIP')
+options=('debug')
pkgver() {
cd "${_plug}"
- echo "$(git describe --long --tags | tr - .)"
+ echo "$(git describe --long --tags | tr - . | tr -d v)"
}
prepare() {
mkdir -p build
- cd "${_plug}"
-
sed 's|$(pkgdatadir)|/usr/lib/vapoursynth|g' \
- -i Makefile.am
-
- ./autogen.sh
+ -i "${_plug}/Makefile.am"
}
build() {
- cd build
+ cd "${_plug}"
+ ./autogen.sh
+ cd "${srcdir}/build"
../"${_plug}"/configure \
--prefix=/usr \
--libdir=/usr/lib/vapoursynth