summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072024-03-29 03:02:19 +0100
committersL1pKn072024-03-29 03:02:19 +0100
commit663af3b6d80a937fd0a9bc6d5c9236f4cbfa15fe (patch)
tree6df47a3a3cf69a150dce1f2c143306c67abedb08
downloadaur-vapoursynth-plugin-vscomplexpr-git.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD62
3 files changed, 82 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c22512346e9e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = vapoursynth-plugin-vscomplexpr-git
+ pkgdesc = Plugin for Vapoursynth: vscomplexpr (GIT version)
+ pkgver = r49.3248547
+ pkgrel = 1
+ url = https://github.com/Irrational-Encoding-Wizardry/vapoursynth-complexpr.git
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ depends = vapoursynth
+ provides = vapoursynth-plugin-vscomplexpr
+ conflicts = vapoursynth-plugin-vscomplexpr
+ options = debug
+ source = vscomplexpr::git+https://github.com/Irrational-Encoding-Wizardry/vapoursynth-complexpr.git
+ sha256sums = SKIP
+
+pkgname = vapoursynth-plugin-vscomplexpr-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..39bed8b338ea
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,62 @@
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+
+_plug=vscomplexpr
+pkgname=vapoursynth-plugin-${_plug}-git
+pkgver=r49.3248547
+pkgrel=1
+pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
+arch=('x86_64')
+url='https://github.com/Irrational-Encoding-Wizardry/vapoursynth-complexpr.git'
+license=('MIT')
+depends=('vapoursynth')
+makedepends=('git')
+provides=("vapoursynth-plugin-${_plug}")
+conflicts=("vapoursynth-plugin-${_plug}")
+source=("${_plug}::git+https://github.com/Irrational-Encoding-Wizardry/vapoursynth-complexpr.git")
+sha256sums=('SKIP')
+options=('debug')
+
+pkgver() {
+ cd "${_plug}"
+# echo "$(git describe --long --tags | tr - . | tr -d r)"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "${_plug}"
+
+ rm -fr kernel/VapourSynth3.h
+ sed -e 's|"VapourSynth4.h"|<VapourSynth4.h>|g' \
+ -e 's|"VSHelper4.h"|<VSHelper4.h>|g' \
+ -i exprdebug.cpp \
+ -i exprfilter.cpp \
+ -i plugin.h \
+ -i kernel/cpulevel.cpp \
+ -i expr/expr.cpp \
+ -i expr/interpreter.h
+ sed 's|VSPresetFormat|VSPresetVideoFormat|g' -i exprdebug.cpp
+
+ echo "all:
+ g++ -shared -std=c++17 -lstdc++ -Wall -fPIC ${CFLAGS} ${CPPFLAGS} -Ofast -flto -fno-signed-zeros -fno-trapping-math -frename-registers -fopenmp -D_GLIBCXX_PARALLEL -D M_PI=3.141592653589793f -D VS_TARGET_CPU_X86 -Wregister -Wno-ignored-attributes -I. -I./expr -I./kernel $(pkg-config --cflags vapoursynth) -o plugin.o plugin.cpp
+ g++ -shared -std=c++17 -lstdc++ -Wall -fPIC ${CFLAGS} ${CPPFLAGS} -Ofast -flto -fno-signed-zeros -fno-trapping-math -frename-registers -fopenmp -D_GLIBCXX_PARALLEL -D M_PI=3.141592653589793f -D VS_TARGET_CPU_X86 -Wregister -Wno-ignored-attributes -I. -I./expr -I./kernel $(pkg-config --cflags vapoursynth) -o exprfilter.o exprfilter.cpp
+ g++ -shared -std=c++17 -lstdc++ -Wall -fPIC ${CFLAGS} ${CPPFLAGS} -Ofast -flto -fno-signed-zeros -fno-trapping-math -frename-registers -fopenmp -D_GLIBCXX_PARALLEL -D M_PI=3.141592653589793f -D VS_TARGET_CPU_X86 -Wregister -Wno-ignored-attributes -I. -I./expr -I./kernel $(pkg-config --cflags vapoursynth) -o exprdebug.o exprdebug.cpp
+ g++ -shared -std=c++17 -lstdc++ -Wall -fPIC ${CFLAGS} ${CPPFLAGS} -Ofast -flto -fno-signed-zeros -fno-trapping-math -frename-registers -fopenmp -D_GLIBCXX_PARALLEL -D M_PI=3.141592653589793f -D VS_TARGET_CPU_X86 -Wregister -Wno-ignored-attributes -I. -I./expr -I./kernel $(pkg-config --cflags vapoursynth) -o expr/expr.o expr/expr.cpp
+ g++ -shared -std=c++17 -lstdc++ -Wall -fPIC ${CFLAGS} ${CPPFLAGS} -Ofast -flto -fno-signed-zeros -fno-trapping-math -frename-registers -fopenmp -D_GLIBCXX_PARALLEL -D M_PI=3.141592653589793f -D VS_TARGET_CPU_X86 -Wregister -Wno-ignored-attributes -I. -I./expr -I./kernel $(pkg-config --cflags vapoursynth) -o expr/interpreter.o expr/interpreter.cpp
+ g++ -shared -std=c++17 -lstdc++ -Wall -fPIC ${CFLAGS} ${CPPFLAGS} -Ofast -flto -fno-signed-zeros -fno-trapping-math -frename-registers -fopenmp -D_GLIBCXX_PARALLEL -D M_PI=3.141592653589793f -D VS_TARGET_CPU_X86 -Wregister -Wno-ignored-attributes -I. -I./expr -I./kernel $(pkg-config --cflags vapoursynth) -o expr/jitcompiler_x86.o expr/jitcompiler_x86.cpp
+ g++ -shared -std=c++17 -lstdc++ -Wall -fPIC ${CFLAGS} ${CPPFLAGS} -Ofast -flto -fno-signed-zeros -fno-trapping-math -frename-registers -fopenmp -D_GLIBCXX_PARALLEL -D M_PI=3.141592653589793f -D VS_TARGET_CPU_X86 -Wregister -Wno-ignored-attributes -I. -I./expr -I./kernel $(pkg-config --cflags vapoursynth) -o expr/jitcompiler.o expr/jitcompiler.cpp
+ g++ -shared -std=c++17 -lstdc++ -Wall -fPIC ${CFLAGS} ${CPPFLAGS} -Ofast -flto -fno-signed-zeros -fno-trapping-math -frename-registers -fopenmp -D_GLIBCXX_PARALLEL -D M_PI=3.141592653589793f -D VS_TARGET_CPU_X86 -Wregister -Wno-ignored-attributes -I. -I./expr -I./kernel $(pkg-config --cflags vapoursynth) -o kernel/cpufeatures.o kernel/cpufeatures.cpp
+ g++ -shared -std=c++17 -lstdc++ -Wall -fPIC ${CFLAGS} ${CPPFLAGS} -Ofast -flto -fno-signed-zeros -fno-trapping-math -frename-registers -fopenmp -D_GLIBCXX_PARALLEL -D M_PI=3.141592653589793f -D VS_TARGET_CPU_X86 -Wregister -Wno-ignored-attributes -I. -I./expr -I./kernel $(pkg-config --cflags vapoursynth) -o kernel/cpulevel.o kernel/cpulevel.cpp
+ g++ -shared -fPIC ${LDFLAGS} -o libvscomplexpr.so plugin.o exprfilter.o exprdebug.o expr/expr.o expr/interpreter.o expr/jitcompiler_x86.o expr/jitcompiler.o kernel/cpulevel.o kernel/cpufeatures.o" > Makefile
+
+}
+
+build() {
+ make -C "${_plug}"
+}
+
+package() {
+ cd "${_plug}"
+ install -Dm755 "lib${_plug}.so" "${pkgdir}/usr/lib/vapoursynth/lib${_plug}.so"
+
+# install -Dm644 README.md "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/README.md"
+}