summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcnf3rd2023-10-19 10:58:03 +0300
committercnf3rd2023-10-19 10:58:03 +0300
commit2252ed0cafcc27da83b832b13b64fa1d12c03c39 (patch)
treec2d3c17166ed7dff670b844c601f2590a10f76e1
downloadaur-vapoursynth-plugin-vssource-git.tar.gz
Initial commit
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD48
2 files changed, 73 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f3700e56aa5b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = vapoursynth-plugin-vssource-git
+ pkgdesc = Plugin for Vapoursynth: vssource (GIT version)
+ pkgver = 0.9.5.3.ge2220bf
+ pkgrel = 1
+ url = https://github.com/Irrational-Encoding-Wizardry/vs-source.git
+ arch = any
+ license = GPL
+ makedepends = git
+ makedepends = python-build
+ makedepends = python-wheel
+ makedepends = python-installer
+ makedepends = python-setuptools
+ depends = vapoursynth
+ depends = vapoursynth-plugin-vstools
+ depends = vapoursynth-plugin-bestsource
+ depends = vapoursynth-plugin-lsmashsource
+ depends = vapoursynth-plugin-d2vsource
+ depends = vapoursynth-plugin-dgdecodenv
+ depends = vapoursynth-plugin-imwri
+ provides = vapoursynth-plugin-vssource
+ conflicts = vapoursynth-plugin-vssource
+ source = vssource::git+https://github.com/Irrational-Encoding-Wizardry/vs-source.git
+ sha256sums = SKIP
+
+pkgname = vapoursynth-plugin-vssource-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d2420ff06ff0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# Maintainer: cnf3rd <subs.in.tokyo@gmail.com>
+
+_plug=vssource
+pkgname=vapoursynth-plugin-${_plug}-git
+pkgver=0.9.5.3.ge2220bf
+pkgrel=1
+pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
+arch=('any')
+url='https://github.com/Irrational-Encoding-Wizardry/vs-source.git'
+license=('GPL')
+depends=(
+ 'vapoursynth'
+ 'vapoursynth-plugin-vstools'
+ 'vapoursynth-plugin-bestsource'
+ 'vapoursynth-plugin-lsmashsource'
+ 'vapoursynth-plugin-d2vsource'
+ 'vapoursynth-plugin-dgdecodenv'
+ 'vapoursynth-plugin-imwri'
+)
+makedepends=(
+ 'git'
+ 'python-build'
+ 'python-wheel'
+ 'python-installer'
+ 'python-setuptools'
+)
+provides=("vapoursynth-plugin-${_plug}")
+conflicts=("vapoursynth-plugin-${_plug}")
+source=("${_plug}::git+https://github.com/Irrational-Encoding-Wizardry/vs-source.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${_plug}"
+ echo "$(git describe --long --tags | tr - . | tr -d v)"
+}
+
+build() {
+ cd "${_plug}"
+ python -m build --wheel --no-isolation
+}
+
+package() {
+ cd "${_plug}"
+ python -m installer --destdir="${pkgdir}" dist/*.whl
+
+ install -Dm644 README.md "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/README.md"
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}