summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsatcom8862020-06-29 22:10:04 +0200
committersatcom8862020-06-29 22:10:04 +0200
commit51a6e1adcb140c932b1f58943374cc505695f35f (patch)
tree77c28a6a11d0e3ae8f2ad03276ba82fe6c83a900
parent84a888a45fcaef29d99cb5630bcbbe64e5b90b00 (diff)
downloadaur-51a6e1adcb140c932b1f58943374cc505695f35f.tar.gz
First attempt at separating the packages
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD37
2 files changed, 12 insertions, 38 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e7f3c1b21249..182118ac7ee0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = vc4cl-git
pkgdesc = VC4CL is an implementation of the OpenCL 1.2 standard for the VideoCore IV GPU.
pkgver = 1
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/doe300/VC4CL
arch = any
license = MIT
@@ -16,16 +16,9 @@ pkgbase = vc4cl-git
provides = opencl-pi
provides = opencl-vc4
provides = opencl-driver
- conflicts = vc4c-git
- conflicts = vc4clstdlib-git
- source = VC4C::git+https://github.com/doe300/VC4C/
- source = VC4CL::git+https://github.com/doe300/VC4CL/
- source = VC4CLStdLib::git+https://github.com/doe300/VC4CLStdLib/
- source = auto_dummy.patch
+ provides = vc4-opencl
+ source = VC4CL.tar.gz::https://github.com/doe300/VC4CL/archive/master.tar.gz
md5sums = SKIP
- md5sums = SKIP
- md5sums = SKIP
- md5sums = e409cafcdc79aa53aef1484e53bd25e7
pkgname = vc4cl-git
diff --git a/PKGBUILD b/PKGBUILD
index f23b9ff1de82..3b785fecf07d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=vc4cl-git
pkgver=1
-pkgrel=2
+pkgrel=3
pkgdesc="VC4CL is an implementation of the OpenCL 1.2 standard for the VideoCore IV GPU."
arch=('any')
url="https://github.com/doe300/VC4CL"
@@ -11,38 +11,19 @@ groups=()
depends=('llvm' 'clinfo' 'ocl-icd')
makedepends=('wget' 'gcc' 'cmake' 'clang' 'opencl-headers')
optdepends=()
-conflicts=('vc4c-git' 'vc4clstdlib-git')
-provides=('opencl-pi' 'opencl-vc4' 'opencl-driver')
-source=("VC4C::git+https://github.com/doe300/VC4C/" "VC4CL::git+https://github.com/doe300/VC4CL/" "VC4CLStdLib::git+https://github.com/doe300/VC4CLStdLib/" "auto_dummy.patch")
-md5sums=('SKIP' 'SKIP' 'SKIP' 'e409cafcdc79aa53aef1484e53bd25e7')
+requires=('vc4c-git')
+provides=('opencl-pi' 'opencl-vc4' 'opencl-driver' 'vc4-opencl')
+source=("VC4CL.tar.gz::https://github.com/doe300/VC4CL/archive/master.tar.gz")
+md5sums=('SKIP')
build() {
- mkdir -p $srcdir/VC4CL/build
- mkdir -p $srcdir/VC4C/build
- mkdir -p $srcdir/VC4CLStdLib/build
- cd $srcdir/VC4CLStdLib/build
- cmake ..
+ mkdir -p $srcdir/VC4CL-master/build
+ cd $srcdir/VC4CL-master/build
+ cmake "$srcdir/VC4CL-master" -DCMAKE_BUILD_TYPE=Release -DMULTI_THREADED=true -DCLANG_FOUND=/usr/bin/clang -DVC4CL_STDLIB_DIR=/usr/local/include/vc4cl-stdlib
make
- cd ../..
- cd VC4C/build
- cmake ..
- make
- cd ../..
- cd VC4CL/build
- cmake ..
- make
- cd ../..
-}
-
-prepare() {
- patch -R $srcdir/VC4C/src/ProcessUtil.cpp $srcdir/auto_dummy.patch
}
package() {
- cd $srcdir/VC4CLStdLib/build
- make DESTDIR="$pkgdir"/ install
- cd $srcdir/VC4C/build
- make DESTDIR="$pkgdir"/ install
- cd $srcdir/VC4CL/build
+ cd $srcdir/VC4CL-master/build
make DESTDIR="$pkgdir"/ install
}