summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsatcom8862020-06-24 12:18:05 +0200
committersatcom8862020-06-24 12:18:05 +0200
commit84a888a45fcaef29d99cb5630bcbbe64e5b90b00 (patch)
tree65d4693386e14914c4a71d8e4595623505fc7749
parent2a745caab0c30a00a954b8a27721225778c17f3f (diff)
downloadaur-84a888a45fcaef29d99cb5630bcbbe64e5b90b00.tar.gz
Added the patch for vc4c
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD15
-rw-r--r--auto_dummy.patch12
3 files changed, 32 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e8de531d8f04..e7f3c1b21249 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,26 +1,31 @@
pkgbase = vc4cl-git
pkgdesc = VC4CL is an implementation of the OpenCL 1.2 standard for the VideoCore IV GPU.
pkgver = 1
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/doe300/VC4CL
arch = any
license = MIT
+ makedepends = wget
+ makedepends = gcc
makedepends = cmake
- makedepends = git
- makedepends = make
+ makedepends = clang
+ makedepends = opencl-headers
depends = llvm
- depends = gcc
- depends = opencl-headers
+ depends = clinfo
depends = ocl-icd
provides = opencl-pi
provides = opencl-vc4
provides = opencl-driver
+ conflicts = vc4c-git
+ conflicts = vc4clstdlib-git
source = VC4C::git+https://github.com/doe300/VC4C/
source = VC4CL::git+https://github.com/doe300/VC4CL/
source = VC4CLStdLib::git+https://github.com/doe300/VC4CLStdLib/
+ source = auto_dummy.patch
md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
+ md5sums = e409cafcdc79aa53aef1484e53bd25e7
pkgname = vc4cl-git
diff --git a/PKGBUILD b/PKGBUILD
index c2d3a11f0e1c..f23b9ff1de82 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,18 +2,19 @@
pkgname=vc4cl-git
pkgver=1
-pkgrel=1
+pkgrel=2
pkgdesc="VC4CL is an implementation of the OpenCL 1.2 standard for the VideoCore IV GPU."
arch=('any')
url="https://github.com/doe300/VC4CL"
license=('MIT')
groups=()
-depends=('llvm' 'gcc' 'opencl-headers' 'ocl-icd')
-makedepends=('cmake' 'git' 'make')
+depends=('llvm' 'clinfo' 'ocl-icd')
+makedepends=('wget' 'gcc' 'cmake' 'clang' 'opencl-headers')
optdepends=()
+conflicts=('vc4c-git' 'vc4clstdlib-git')
provides=('opencl-pi' 'opencl-vc4' 'opencl-driver')
-source=("VC4C::git+https://github.com/doe300/VC4C/" "VC4CL::git+https://github.com/doe300/VC4CL/" "VC4CLStdLib::git+https://github.com/doe300/VC4CLStdLib/")
-md5sums=('SKIP' 'SKIP' 'SKIP')
+source=("VC4C::git+https://github.com/doe300/VC4C/" "VC4CL::git+https://github.com/doe300/VC4CL/" "VC4CLStdLib::git+https://github.com/doe300/VC4CLStdLib/" "auto_dummy.patch")
+md5sums=('SKIP' 'SKIP' 'SKIP' 'e409cafcdc79aa53aef1484e53bd25e7')
build() {
mkdir -p $srcdir/VC4CL/build
@@ -33,6 +34,10 @@ build() {
cd ../..
}
+prepare() {
+ patch -R $srcdir/VC4C/src/ProcessUtil.cpp $srcdir/auto_dummy.patch
+}
+
package() {
cd $srcdir/VC4CLStdLib/build
make DESTDIR="$pkgdir"/ install
diff --git a/auto_dummy.patch b/auto_dummy.patch
new file mode 100644
index 000000000000..fce18d1d464b
--- /dev/null
+++ b/auto_dummy.patch
@@ -0,0 +1,12 @@
+--- ProcessUtil.cpp 2020-06-21 22:41:53.008149222 +0200
++++ ProcessUtil.cpp.bak 2020-06-21 22:40:22.793443863 +0200
+@@ -247,8 +247,7 @@
+ {
+ in.read(buffer.data(), buffer.size());
+ numBytes = in.gcount();
+- auto dummy = write(pipes[STD_IN][WRITE], buffer.data(), static_cast<std::size_t>(in.gcount()));
+- (void)dummy;
++ write(pipes[STD_IN][WRITE], buffer.data(), static_cast<std::size_t>(in.gcount()));
+ if(numBytes != buffer.size())
+ break;
+ }