summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsatcom8862019-09-21 22:18:49 +0200
committersatcom8862019-09-21 22:18:49 +0200
commit95829c2e8cd607d0cca672aa89f60d2094c60b95 (patch)
tree678a76b80adefe93472290722598389e79807871
downloadaur-95829c2e8cd607d0cca672aa89f60d2094c60b95.tar.gz
Initial commit
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD43
2 files changed, 69 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..12714b91ff4e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = vc4c-git
+ pkgdesc = VC4CL is an implementation of the OpenCL 1.2 standard for the VideoCore IV GPU.
+ pkgver = 1
+ pkgrel = 1
+ url = https://github.com/doe300/VC4CL
+ arch = any
+ license = MIT
+ makedepends = cmake
+ makedepends = git
+ makedepends = make
+ depends = llvm
+ depends = gcc
+ depends = opencl-headers
+ depends = ocl-icd
+ provides = opencl-pi
+ provides = opencl-vc4
+ provides = opencl-driver
+ source = VC4C::git+https://github.com/doe300/VC4C/VC4C.git
+ source = VC4CL::git+https://github.com/doe300/VC4CL/VC4CL.git
+ source = VC4CLStdLib::git+https://github.com/doe300/VC4CLStdLib/VC4CLStdLib.git
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+
+pkgname = vc4c-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..04dc1f35a98a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: satcom886 <rostik.medved@gmail.com>
+
+pkgname=vc4c-git
+pkgver=1
+pkgrel=1
+pkgdesc="VC4CL is an implementation of the OpenCL 1.2 standard for the VideoCore IV GPU."
+arch=('any')
+url="https://github.com/doe300/VC4CL"
+license=('MIT')
+groups=()
+depends=('llvm' 'gcc' 'opencl-headers' 'ocl-icd')
+makedepends=('cmake' 'git' 'make')
+optdepends=()
+provides=('opencl-pi' 'opencl-vc4' 'opencl-driver')
+source=("VC4C::git+https://github.com/doe300/VC4C/VC4C.git" "VC4CL::git+https://github.com/doe300/VC4CL/VC4CL.git" "VC4CLStdLib::git+https://github.com/doe300/VC4CLStdLib/VC4CLStdLib.git")
+md5sums=('SKIP' 'SKIP' 'SKIP')
+
+build() {
+ mkdir -p $srcdir/VC4CL/build
+ mkdir -p $srcdir/VC4C/build
+ mkdir -p $srcdir/VC4CLStdLib/build
+ cd $srcdir/VC4CLStdLib/build
+ cmake ..
+ make
+ cd ../..
+ cd VC4C/build
+ cmake ..
+ make
+ cd ../..
+ cd VC4CL/build
+ cmake ..
+ make
+ cd ../..
+}
+
+package() {
+ cd $srcdir/VC4CLStdLib/build
+ make DESTDIR="$pkgdir"/ install
+ cd $srcdir/VC4C/build
+ make DESTDIR="$pkgdir"/ install
+ cd $srcdir/VC4CL/build
+ make DESTDIR="$pkgdir"/ install
+}